UDM-Pro firmware update 1.9.2 issues

Contains Ubiquiti vs. rant, read only if you want. Thank you people at lawrencesystems.com who helped me, I appreciate you.

Hi,
My name is Ioan Koka, from Romania. I own an Ubiquiti UDM-Pro and this is my story.
I cannot say that I am any kind of IT god with special skills. What I am, an honest, passionate IT Tech, that appreciates good hardware an software. I love to learn from anyone, I enjoy best practices, so you can guess where this goes.

Since i bought this UDM-Pro machine I had nothing but troubles with it.
At setup I had booting issues and I could not login to the box right after setup completion. Ubiquiti had my account locked from some reasons (maybe too many failed logins) so I could not use the machine. I have opened a ticket with their support, somebody unlocked my account but they never said they did unlock it. What they did as I see this is a practice at Ubiquiti lately, they waited for me to figure it out by myself. Anyway, after a few days they suggested to upgrade the firmware on UDM-Pro to 1.9.2 and also change my password on unifi.ui.com. I did all that.

Now I have opened another ticket with Ubiquiti support, because with the 1.9.2. firmware this machine became a nightmare. GUI is not working properly, is becoming unresponsive even twice per day. This is unacceptable. I have started researching this issue by myself because Ubiquiti support answers did not satisfy my expectance. They escalated this thicket to Tier 2 Team at the 3-rd email and every one the support team member asked me the same basic stuff, including Tier 2 Team. What firmware I use, if I have restarted the machine, if I con login locally, you know…

What the machine does, it freezes when is used normally, visiting 1-2 times per day the GUI interface, using normally the Protect app on phone. The machine starts the isues by showing offline in ubiquiti.ui.com but never reporting it. Because the machine is not totally offline, it is working, We can login via SSH, forwarded ports are working, we can use OpenVPN to get to an inside network based machine. So I can assume that the router is working, only GUI is dead. We have tried to switch to Classic view, turn off and on dark theme, not helping any of those. The freezing is random but happens.

As an IT Tech I do have something to say about it, as I already did on Ubiquiti community.
This UDM-Pro came with a “release” version of frmware as I understand any piece of hardware should be when released to the market. That firmware was full of bug as I understand and they fixed things in firmware 1.9.2 that also is a “release” version.
Well, firmware version is full of Beta things and the NEW GUI is Alpha! Yes, Alpha!
This is not acceptable. I am OK with tinkering in a lab at your own risk. But this machine is bought by clients to use in real life, for business as well. There’s no way I can accept Alpha and Beta stuff mixed in a “release” version of firmware that goes into production.

At our company we also updated 5 of Cloud Key Gen2 firmware controllers to the latest firmware 2.0.27
Guess what? 2 controllers went offline in the first 2 days and another one went offline yesterday. This is not random. We had these controllers working for months and years. We never-ever had to restart a controller.

I hope you can understand why I wrote this, if it is too much, fell free to take if offline and please notice me about. I do take full responsibility for my text. But i would very much ask you to let everyone know that best practices is a thing in networking and general computing.
And mixing alpha and beta stuff, or general pre-release stuff into a firmware that is marked as “release”, should not happen and should not be accepted. Again, real life and production is not a lab.

Here is my post at Ubiquiti community site:
https://community.ui.com/questions/UMD-Pro-it-is-not-so-Pro-anymore-after-1-9-2-Update/17d3757f-4de8-4e14-9704-b30e31a0a9b2

1 Like

And thisis Ubiquiti’s answer to the issue:

Hi,

I’d suggest updating the UDM-Pro to v1.9.3 using the recovery mode and let me know if it is still crashing. You can download it from here: https://community.ui.com/releases/UniFi-Dream-Machine-Firmware-1-9-3/c0eef9ce-8bc8-4324-bc5a-dd6ad8520ee0

If it still crashes and you cannot SSH then please confirm whether you have SSH enabled under the Settings > Advanced tab in the UDM-Pro.

Thanks!

Best,

UI Support
Ubiquiti Inc.

So i did the update to firmware version 1.9.3 and after restart the first thing I have experienced is in the picture.

Hey Ioan,

That is the same error I was hitting that locked my client out of their UDM Pro.

Essentially we were trying to enter static IP info on the WAN interface and realized we were given incorrect information, which caused them to lose their internet connection. Once we confirmed the correct IP info, we attempted to login locally to change it on the WAN interface and received this error. This was using the new UI. The workaround for us turned out to be doing a full reboot, as it would temporarily allow you access to the UI but only for a short period of time until you were again locked out. After a couple of tries we were just fast enough to change interface back to Classic and the WAN info to what it was supposed to be and the issue seemed to stop.

I am not sure what caused that to happen, but losing internet access shouldn’t have been a factor in losing local access. For now I’m suggesting to stay off of the new UI since it’s still in development.

2 Likes

Hello,

I am sorry you are having a poor experience with your UDMp. There are several on the Unifi forums that have made suggestions to those who run into issues such as your self. I have a UDMP in a production setup for a small school and “knocking on wood” have not had the issues many such as your self are experiencing.

I went from 1.8.6 to 1.9.3 as the comments in the release forums had me wait a bit longer even though I had already updated the controller to 6.0.34 to support the U6 LR we installed to replace the AP-AC-LR’s. I have found, and others; that there are steps that work best for updating the firmware and controllers that yield a more stable environment. I will explain below, also only use the new GUI for what has been migrated and removed from classic, classic GUI is all I use.

First things first. Power cycle the UDMp and make a settings only back up and download a copy for use later. Do a factory reset into recover mode.

Once this is completed and the system is accessible, before restoring any settings, update the firmware to 1.9.3, once firmware is updated, before re adopting your elements restart the machine. unless you want to use a beta controller, 6.2.13 has been good for me, use the release 6.0.34 and switch and non U6 AP firmware 5.43.34.

For future, the process I use to update any equipment first thing is to power cycle any device prior to firmware update. Make a settings backup only. Reboot the device again, update, restart the device. If this is to update a UDM/usg continue (at this point a few do a factory restore then restore from the settings backup), I have not had to do that but once. It will take 10-20 minutes for all the devices to reconnect, if they do not; come back on line or show disconnected, cycle the power on the device first before you reset/ forget and re adopt them.

Also make sure you make note of your set inform user name and password so you can re adopt your network devices after the factory reset, and restore of settings.

Is it a pain in tail when it gets to the point you are experiencing, absolutely. Hopefully this will help resolve your issues and you will see a more stable experience moving forward.

Cheers.

1 Like

Why do you use Ubiquiti’s cloud portal?
You can access your UDM-Pro directly from your network without any problems. Then there is no offline.

I received my UDM Pro this week but haven’t set it up yet. I’m currently using the Synology RT2600ac with a couple of MR2200’s.

Could anyone reassure me that issues described above are rare? I abandoned using Netgear routers a few years ago due to firmware issues and poor customer support.

I had assumed that Unify was premium equipment and would never expect unstable releases to be pushed out.

Have I made a huge mistake moving to Unify? What alerted me to question this was 1) the recommendation on YouTube videos to turn off auto updates - surely for security auto updates should be turned on and the firmware should be trusted to be stable once given the all clear for a stable auto update 2) a few of the popular YouTube channels I have watched recently said they had issues like this themselves, which would suggest it’s a common problem.

Can I trust ubiquity?

They seem to have become a bit more buggy lately with their UDM/UDM-Pro. We don’t recommend the UniFi routing equipment but we do still deploy their switches and AP’s.