Ubuntu unifi controller install

My controller is down longer stupid mistake on my part… So I figured I would do it on a VM on Ubuntu, I followed this guide and it seems to not work with the last step. Does anyone know of all the dependencies?

Now I am using 18.04.02 Desktop and have attempted the newest 20 release but nothing.

I use Debian but I have not tried it on Ubuntu.

Seems like I am not the only one having this issue, based off UI forums. What Debian are you using? I picked up debian-live-10.4.0-amd64-cinnamon the other day but have not tried it.

Might be work giving is a go at this point.

We just use the base Debian 10 net install, no desktop
https://www.debian.org/distrib/netinst

for some reason its removing unifi when I urn the -f command. I was hoping to not do a windows VM but at this point I think I should call it.

I have tried to install the “dependency’s” solo but they are not working.

have you trtied the Unfi install script from their site?

I am runing my controller on Ubuntu 18.04 using it and have been able to also update with no issues.

You talking about this one? I have not I am not a big fan of running scripts I have not fully reviewed with my script guy.

@Astraea
Thanks, giving it a shot now.

@Astraea It worked thanks, going to have my guy look at the script in the mean time I put it in its own environment .

I use Debian as well. I don’t use UnFi as a repository; I just download the new deb file with each version and install it using dpkg.