Ubiquiti UniFi USW Flex Mini 5-Port Budget Friendly Managed Gigabit Switch

1 Like

This device is almost perfect, the price being the BEST thing about it
I needed something to put in my home office to connect the printer and WD storage, my computer.

If only it had

  1. Different color, white is too in the face, something like silver (similar to the other Unifi switch)
  2. Atleast 1 POE Pass-through, So i put one in every room and connect an AP or a camera if needed. But i can understand that they were try to hit a price point.

Non the less excellent entry to the line up.


Ideal for field work and travel paired with the Netgate 1100.

1 Like

I’ll be ordering several of these as soon as I can find them in stock. I recently ordered and installed a Netgear GS305E for my 10x12 shed; there’s a UniFi AC-M-PRO, Chromecast, and computer (for my son’s online drum lessons) in there. The Netgear works fine and was easy to configure, but it would be easiest/best to stay in the UniFi ecosystem since I already have two UniFi switches and three APs. I also have a couple of TP-Link Easy Smart switches in bedrooms; it would good to replace those with the Flex Mini as well.

Yea wishing it had at least one POE+ out too - but for the price it seems pretty good.

Tom, big fan of your videos on YouTube. Keep them coming.

I have three 5-port switches that are having issues connecting to the controller. I am currently at level 3 tech support at UI but still am having issues.
My issue started when I had one 5-port mini connected to the controller, everything was great when I first installed, adopted with no issues. After about 3 or 4 days I noticed the switch was no longer adopted but still had a blue led. Tried to adopt again but kept failing after many tries. I have tried the following: Resetting the devise, per UI and Copying my controller setup to my laptop and trying to adopt directly to my laptop using.

The only way any of the three switches will adopt is to set my laptop to a static IP address, and then install a the controller, set the controller host name to and check the override box below the host name/ip. After adoption I made sure the firmware was updated and then clicked forget. Tried installing on my controller and the same as before the switches will not connect.

My setup is a PFSense router, My controller software is running in a docker container, I have a 8-port POE switch, and 2 Pro Access Points in my home (old house with metal mesh in the walls). and my home IP Range is UI asked me to update to 6.0.22 in our last emails.

Have you seen this before? Should I change my IP Range to

Thank you advance

We have a handful of these switched deployed at different ranges without issues. So I am not certain what the issue is.

Update: The controller was the issue. I switched from 6.0.20 to 6.0.23 and all of my problems went away.

These little switches are great for adding a port on your desktop or TV stand.

There is a problem with these switches reported to Ubiquiti tech support - awaiting their response.
This problem does NOT affect switching operation or PoEe operation.

On a Windows 10 based Unifi controller software - the switches can be adopted right away.
But on a Linux based system they are not recognised.

These switches do not have SSH protocol built into them and therefore the command ‘set-inform’ cannot be used to ‘point’ them the the Unifi server.

In my case, I have a PFSENSE firewall in place and not the Ubiquiti one. My Unifi server is running within a jail on my FreeNAS server.

I do not have a fix for this but just to let other be aware of this issue. I am running V6.0.43 on the FreeNAs server and 6.0.45 Windows version.

1 Like

But it makes for a good portable field switch when you need to have multiple laptops connected away from the rack.

One thing to note about these great little switches is that they do NOT support custom port profiles so it’s impossible to customise your trunk ports. You can only chose between a single VLAN assigned to a port or all VLANs with VLAN1 as the native one.
You can not however assign VLAN20 as the native one plus VLAN 30 tagged for example. It’s either VLAN1 plus all of the others tagged or just a single one untagged. The confusing thing is that in the Unifi Controller there’s the “edit port profles” that you can click but after creating a custom port profile with lets say VLAN20 plus VLAN30 tagged that port profile will simply not show up in the menu of the switch with no GUI feedback telling you that they won’t work so it seems like you ran into a bug or it doesn’t provision properly. After digging around I read that they simply don’t support custom port profiles for these switches :frowning:
It’s something they obviously do not put on the front pages at Ubiquity but it’s an important detail.

Unless I am missing something…