Trying to update an Dell R210 II

As the title says, I am trying to update my Dell R210 II. It’s bios is 2.0.5, which is very outdated, and I am trying to bring it up to 2.10.0, which is the current version.

Along that I am also trying to get everything else updated, because I am having some fan issues. When idle the fans spin around 3300 rpm, which is fine, and under load they spin up to around 4500-6000 rpm, which is also fine… The problem is, if the temperature gets above 65c, the fans throttle down to 3300 rpm again, and there they just stay. I have tried to let it run with the load on for a while, while closely monitoring it. With the cpu at 95c, the fans were stilling only doing 3300 rpm, and I terminated the application.

So now I am trying to update everything, in the hope some of it will involve the software controlling the fans.

In bios I have set the fans to “Maximum performance”, and only allowing the OS to control processor settings. I have also tried all other combinations of OS and maximum performance there is, nothing changes.

To update I have tried to boot into Windows PE, and use Dell’s bios updater for windows, when I click install it does a quick blink and then claims to be done.
I have also tried to make a iso with Dell EMC Repository Manager, where it also installs and ends up with needing a restart to apply the update. As you probably guessed, none of those worked. They dont show any errors, and just asks for a reboot. And after the reboot, the bios is still 2.0.5

:point_right: I do not have iDRAC yet, so I can’t try to do it through that. :point_left:

Does anyone here know what can be wrong? My next thing to try is to sacrifice my first born, but I would first have to get a child then, and I would love not having to wait 9 months.

Try to reboot it again, then get back into bios and set all to defaults to get back to the desktop.

Already tried, no change.

Then, try to undo what you did with regards to the Bios settings.
Get back into it and chose a different option, Optimal over performance would be best for an older workstation.


As I stated in the first post too, I have tried all combinations there are, regarding cpu, fan and memory performance. Including entirely disabling manual override.

I am not sure if it makes a difference, but this isnt a workstation, it is an old 1U server.

Two things I notice here.

First, is the jump from 2.0.5 to 2.10.0, I’d be wondering if there isn’t a required middle-version somewhere.

Second, is the Inventory Failure, even Partial as it states, is still technically a failure. I’d be looking here personally. Maybe try a fresh download of the firmware?

As I’m not familiar with that unit, is there perhaps a motherboard jumper that locks the bios from being touched? I’ve seen them before, so it’s something I’d possibly look for.

my 2 pennies

I have tried to update it to just 2.1.2 too, which is the released version right after 2.0.5, that also didnt stick.

I have been looking at that failure message too, some say it is because it does not have the idrac modules in, but besides that I have no idea what it can be, as it does not really give me any clue to what failed.

The locked bios thing is also a good suggestion, but I havent been able to locate one in bios, on the board, and google searches also turned up nothing on that topic.

So I did a quick search and found this, sounds like a solid option, and old school which is always better. :wink:

I have found that one too, and with some more searching, that is also what leads to most systems which are refusing to boot afterwards. So I am holding back from trying that.

Refusing to boot after? That’s not a pleasant thought. If the fans are your only real concern, perhaps try to MacGyver the fans to a separate fan controller? Whatever you try, good luck!

Yea, a bricked bios is something I would really like to avoid.

I have ordered a iDRAC6 Enterprice kit, which should arrive in a few weeks. Hopefully that can help me get all the different components in the server updated.

Maybe I missed it. Did you reset the BIOS from the motherboard jumper?

Yup, I have tried that too.

I have been at this for almost two weeks now :smiley: I so hope iDRAC does some magic and is able to update it all.

@mikey :crossed_fingers::pray:

So, today I got brave, and I tried the wipe and force update.

I only went one version up from 2.0.5 to 2.1.2, just to not forcing it to make a jump larger than the versions could handle.

So it put 2.1.2 on, it went smooth, no errors.

And after a reboot, it started up… with 2.0.5 on.

But hey, now the loading bar on the dell splash screen is actually moving, before this it was just at 100% as soon as the screen was showing, now it moves up.

I did some more digging into what the other jumpers on the mainboard does, they seem to be used for “DO NOT TOUCH THESE!!!

Don’tcha just love days when you get Brave and nothing bad happens. :+1:

Considering it actually did something positive, with the splash screen, I’d personally be brave again, and re-run the force update to 2.1.2. I’ll always look at small gains as forward movement.

Jumpers with, Do Not Touch These by them, statements like that just make me want to mess with them and grin with glee… LoL

Tried to run the update a few times now, only thing happening, is the settings in bios getting lost. :frowning:

I GOT IT UPDATED!!! :muscle: :cupcake::partying_face:

It is now running bios version 2.10.0, which is the newest there is.

The next problem is now, that it is still running at 90c, without turning the fan speed up…

Congrats! :+1:

What was the magic bullet that made it work?

As to the fans, maybe consider replacing one of them, maybe the speed sensor is toast?

All the time, I tried to just take it one version step up, to keep it safe and avoid a problem when jumping multiple versions… Apparently the problem was going from 2.0.5 to 2.1.2 too… Taking it one version further up, with the wipe and force, and it updated as expected. After that I could then take it all the way up to 2.10.0, so now bios is updated.

The fan’s are good, I have tried to monitor the rpm’s and touch them to see them go up and down. I actually did that very early to see which fan number is assigned to which fan.