Trying to setting up my own Multisite Unifi Controller

I am trying to set up a multisite controller system because my brother is not good at anything tecky but wanted to go with a system like mine so he didn’t have to worry about comcast nickel and diming him to death.

I am running an Edgerouter 4 with 3 unifi AP’s in my house. I run the Unifi and UNMS controllers on a freenas Ubuntu 18.04LTS VM and the system works great. I pay for 400 down but i have never seen the system actually get less then 410 down.

I had him get and Edgerouter X and 1 AP (smaller house). I want to just add his equipment to my controllers so i can take care of updates and settings for him so he doesn’t break anything.

I watched both the videos Lawrence posted about hosting your own controller and i must be missing something.

I opened the 3 ports on my Edgerouter and even though i originally added the AP when it was on my network when i installed it at his house it didn’t work at all. and i couldn’t connect to my controller located at my house to change settings. So i took his Edgerouter and Ap back to my house to try and figure this out.

I did have internet wired through the Edgerouter but not at the AP.

My network is a 192.168.1 system. So this time i was thinking set his as 192.168.2 and both have a guest network of 192.168.10. (I didn’t have his edgerouter at first so i had left it as 192.168.1)

Is there a way to adopt these to my controller when they are on my network so when i get to his house they are literally plug and play? And should i add the VLAN for the guest network only to the port that has the AP?

The system can be adopted locally and will work remotely as long as you have the proper hostname here

As Tom says, you have to have the right hostname / IP address when you are remote. If you don’t have a static IP at your house, you will probably want to sign up with a dynamic IP address service to get a hostname that follows your home IP address. Then you can use that address for as the controller Hostname at your brother’s house.

I just have home internet so as far as i know i don’t have a static IP from comcast. Since the controllers are on an Ubuntu VM i need to find a DNS service that works on linux correct?

I found a dns service that would work on the Linux vm and the minute i put in the host name i made all 3 of my AP’s are trying to re adopt and failing.

Do i need to uncheck the Override inform host with controller hostname/ip

I set up the port forwarding on my Edgerouter as seen below.

They point to my FreeNAS ubuntu 18.04 desktop VM which has the latest controler
And now one of my 3 AP’s is giving me a STUN error

And i still can not talk to my Brothers AP or Edgerouter x from my house.

Do i need to create port forwarding rules on my Ubuntu VM the only thing it does i run the controller?

From inside your firewall, can you go to
If it doesn’t work on your LAN, then you have to troubleshoot the firewall settings on the Ubuntu box.

Just tried that and got no connection. Sounds like its a firewall issue.

Thank you for suggesting that.

Just tried opening the ports following the guide here

everything but the ssh. (don’t really need it) everything was accepted.
Even redid my domain and nothing still.

Would a cloud Key be an easier thing to get up and running at this point?