Truenas + syncthing permissions wont work

i did set up syncthing on truenas acording to Toms awsome video, though i cant get the permissions to work it looks like. when i do try to create or sync in a folder in the sync thing on truenas it just say “Failed to create folder root directory mkdir /folder: permission denied.”

  • i have followed all the steps, a user with UID of 983,
  • the dataset is owned by the user with read, write access.
  • the jail have the exact path as in the video. (/mnt/Main Pool/iocage/jails/SyncThing/root/mnt/SyncThingData)

i´v been over the video several times, and all the settings, but can´t figure out what i am doing wrong,

1 Like

I am having some of the same issues, I tried putting my users Home directory to the syncthing folder and still getting rejected. Let me know if you figure this out I have 15TB of data I need to more before I wipe a raid 10 to expand it.

If you SSH into the TrueNAS system you can go in and confirm the permissions from the command line for the sub folders. If they are missing you apply the permissions recursively via the permissions UI.

hmm ok, it did work, though i had to add the permissions via SSH, i had tried that several times in UI of truenas but the group still did not have permission to write.

So I need to give permissions to /mnt/PlexNAS/iocage/jails/syncthing/ for user sync?

What i did was add permission to the group for the syncthing folder equal to your yes, then i did go in to the UI of truenas and just because did add permissions again recursively to the dataset under pools. i am 100% sure i did try this several times in the UI before but for some reason it did work when i did it this way. don´t know if it is a bug or just me missing something. but i did destroy the jail and plugin and did try it two times with the same result before i did get it to work thanks to Tom.
also, i am not 100% sure i have made everything up to safe standards regarding the permissions right now but it does not madder because it is just my home system with no internet access.

looks like I did the same thing but still getting rejected

then i have no ideah, go over Toms video step by step and se if you can get it to work.

I redid it a few times, I will try it again.

Yeah still not working, after the reattempt the admin portal is not even loading so going to wipe and start over.

After some reading looks like I need to reinstall to 12.0.U2.1

So I have not seen a 100% I need to do a full reinstall to have it at 12.0.U2.1 does anyone know know for this?