Truenas (Source) backup to Synology (Target) via rsync or other methods

Does anyone know if Lawrence has any youtube videos to backup From a Truenas system to a Synology system?
Everything I’m finding on youtube or ixsystems is dated or doesn’t provide enough information.
Is there a way to do this in the GUI with modules, or is SSH the only option?
I’d perfer not to use syncthing, as I’ve had many issues with it in the past with a push configuration when large changes are made.

I’ve found loads of guides to go from Synology to Truenas but not the other way around.

1 Like

Been on my to do to make one, the first issue is that Synology does not properly do Rsync with TrueNAS, but in theory you should be able to mount a folder from the Synology to the TrueNAS and sync. I have not tested this at all.

3 Likes

Hey Tom! Thanks for the reply… I had a brain fart and called you Lawrence :rofl: .
Seems a lot of the problems I ran into is some of this needs to be done via shell.
On both systems, if home folders is not setup on Synology.

Then on Truenas some other things need to be done in shell. I can’t seem to get the Public keys setup properly.

I’m also having a hard time figuring out how to mount remote storage under Truenas. I’ve done this many times on Linux, but not as familiar with Truenas. Looks like you can only do NFS mounts? What i’m reading seems CIFS is not a thing for remote mounts. Can’t find the proper information.
Is there an area to do this in the GUI? I must be missing it!

Anyways thanks for the reply, and look forward to this video!

1 Like

I’ve been trying to figure out how to do something similar from TrueNAS to Unraid. Linus just did a video about using rsnapshot, but they left out all the details on how to actually do it.

I finally managed to get Truenas and Synology talking to each other.
However when I go to create the rsync task it will successfully create.
But I get the follow errors from logs.

Perhaps there is a auxiliary command to disable version mismatch, but I can’t find it.

rsync: on remote machine: --new-compress: unknown option
rsync error: syntax or usage error (code 1) at main.c(1792) [server=3.0.9]
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [sender=3.1.3]

holy shit I got it to finally work.
I’ll make a how to on my blog, and I’ll share the link here.
I still think a video would be better.

2 Likes

its a rough draft, i’ll try and pretty it up later, or never… will see how it goes.
https://blog.filegarden.net/2021/02/24/backup-truenas-to-synology-via-rsync/

2 Likes

Nice write up, can’t help but wonder why Synology did not make this easier.

Me either… This seems unnecessary, and the knowledge surrounding the requirements.
It took me like 40 separate chrome tabs, and a few YouTube videos to piece this all together.
Still may not be the best method…

Hello everyone,

After reading this thread, i don’t know if i’m lucky or unlucky now, but having a TrueNas Core box as a primary NAS and limited budget, my secondary backup is Synology DS218.

There is only 1 to 1 SMB share to backup, from /mnt/MirrorPool/Data TO /volume1/Data.

What are my shots on this ? Should i try implementing the RSync method , or give a try with Syncthing ?
Any suggestions are greatly appreciated.

Syncthing will probably be easier route to go. But you should have no issues setting this up.

Hello Mr. Spencer, thanks for your guide.

I have a question about the step here on Synology:

###Next will require vim or nano###
sudo nano /etc/ssh/sshd_config

does the nano have to be installed on the synology or on the linux machine that i will use to ssh in ?

I’m asking this because there is no nano in the synology packages and Putty (on windows) doesn’t have the nano. So i’m wondering if i need a small debian version as VM. Thank you.

Yes you’ll have to install nano by external repository.

Hello Sir,
i have proceed with your directions and passed the step of editing the sshd_config.

now it seems something is wrong with permissions on the following block:

###Make AUTH Key file###
cd /var/services/homes/rsync
mkdir .ssh
chmod 700 .ssh
touch ~/.ssh/authorized_keys
chmod 600 ~/.ssh/authorized_keys
cd /var/services/homes
sudo chmod 700 rsync

i have tried to ssh and execute above procedure with user rsync and admin, who both of them are in the administrators group and have all the privileges. I have also checked on the shared folder to have read/write permission and rights on the applications.

please note that the path is /volume1/Data/homes/rsync , not /var/services/homes/rsync

Unfortunately I no longer have a Synology to double-check this

I currently have a Synology backing up to 2 seperate Truenas servers using the WebDav function in HyperBackup. The 2 servers are offsite and use a DDNS address for connectivity.

Thanks @canthonysmith i will try that, by reversing source and destination in my case.