TrueNAS: SMB Share write issue, read is fine

I am dual boot and I was able to write and read on my windows side. I decided to move to linux and this is what I have it in my

/etc/fstab file:

// /home/XXXX/IMP-BackUP cifs username=USERNAME,password=PASSWORD 0 0
// /home/XXXX/MainOne cifs username=USERNAME,password=PASSWORD 0 0

I am able to read those files without any issue, but I can’t write in it.

If I mount folder from network discovery file sharing, it works, but not from my main mount folders.

I have done this way in some of my VM and it works fine.
I would appreciate your help.

I don’t have it in fstab I have this in a script I run at startup and yes, it does prompt me for my password.

sudo mount -t cifs // -o username=tom,iocharset=utf8,vers=3.0,uid=lawrencet,noforceuid,gid=lawrencet /mnt/FreeNAS_Video/

Thanks for reply. I made some changes and it worked in my fstab files:

/ /MOUNTPOINT cifs username=SMBUSER,password=PASSWORD,iocharset=utf8,vers=3.0,uid=USER,noforceuid,gid=USER 0 0

1 Like