TrueNAS Scale Nextcloud issues

Hi all,

I was previously running the TrueCharts version of NextCloud on TrueNAS scale, but I’m tired of them making breaking changes every other update.

Decided to try following Tom’s guide for setting up the official image in Scale, and I keep running into issues.

I’ve created 2 datasets - one for data, the other for the database and assigned permissions as Tom did.

However when the container starts it keeps getting stuck on “Deploying 1/2” and never progresses, even if I leave it for 30+ minutes.

The event logs shows this message “Liveness probe failed: Get “http://172.16.80.63:80/status.php”: dial tcp 172.16.80.63:80: connect: connection refused”

Based on the message it sounds like there’s no webserver listening where the container is expecting there to be one, but I have no idea where to go about troubleshooting this. I’ve double and triple checked that the owner and group of the nextcloud data dataset are www-data and have full read-write permissions.

Anyone run into this before, or should I go bother the folks on the IX systems forums? :slight_smile:

Well, right after I posted this I got it to work. I had to toggle the “Flags” option in permissions back to “Basic” instead of “Advanced”. Must have been some flag it was missing.

Now to figure out how to get this to work properly with my reverse proxy…

2 Likes

Just an update, never did get this to work properly. The TrueNAS Scale apps are a dumpster fire with poor documentation, so I gave up and I’m now running NextCloud in docker on another machine, using a docker volume over NFS for the data.

For some reason the official NextCloud image has an nginx reverse proxy in front of it by default that you can’t turn off, which has a hard 302 redirect on any request made to it. (Which results in any request being automatically redirected to the IP address of TrueNAS, instead of letting the proxy sit in front of it with its proper wildcard SSL certificate.)

Maybe someone who knows nginx configurations better than I do can figure out how to disable it.