Truenas: nfsrv_cache_session: no session

I’ve had to move my XCPNG backups to my TrueNAS core box as my Synology finally bit the dust. I’ve been having issues with my backups failing so tonight/this morning I started poking around. XOA was showing **Error** : HTTP connection has timed out as the reason for the backup failing. I did find Tom’s post in the forums about this Backup failing with "Error: HTTP connection has timed out" | XCP-ng and XO forum and have added the file that Oliver suggested and it seems to be working so far, but backups are taking forever still. I also noticed that nsfsrv_cache_session: no session IPaddress=(my XPNNG mgmt IP) was showing repeatedly on the console of my Truenas box.

This is an IX systems TRUENAS-MINI-3.0-X+ box that I stuffed 5 8TB Seagate Ironwolfs into a 5 disk RaidZ2 pool.

I’m certainly not a storage guy - networks are my day job so maybe I’ve botched something up? I’ve tried to not twiddle the knobs so to speak, so it’s pretty much a stock Core install.

I’m sitting at about 41% of the space in the pool used. I did read that one should try and keep things below 80% utilization with ZFS, but I’m not even close to that.

Anyone have any suggestions on what it might be? It seems that it may not only be NFS affected. I was moving a bunch of data over from my windows box via SMB and it seemed to keep pausing as well. At first I thought it was a bad SFP so I swapped that out on the switch side tonight but that didn’t seem to help.


Are you running the latest build of XO because in the forum post you linked there was a bug fix in the xo-server 5.84.2 update.

I just ran an update and tried it again - running commit [0d127] It failed with the same HTTP timeout error.

I’m going to try a different network card in my truenas box and see if maybe it’s a connectivity issue, I have a spare Chelsio NIC that I believe should work.

So I gave up troubleshooting this after changing the NIC didn’t work.

I would login and rerun the VMs that failed individually and they would complete just fine. I was doing that for a few days and then work got busy and I forgot. Tonight I logged in and my backup jobs have run fine for the last two nights. It seems to have fixed itself whatever it was.