Truenas importing existing pool

I am trying to import an existing pool into Truenas Core that originated as a Truenas pool. The data is just for testing. I have been able to import the pool and can view the data in the pool when viewed from the CLI. The issue is when I add permissions and share the pool as an SMB share, I receive “you do not have permission to access” from Windows. I have been able to follow the video “TrueNAS Core: Configuring Shares, Permissions, Snapshots & Shadow Copies” and know this was talked about. Even when I log out and back into windows I get the same error. If I test with a different pool that I create I can mount the SMB share without an issue.

I would like to see if there are any specific items that need to be addressed when adding an existing pool. I’m trying to do it without a config file to see if this can be done. Since I see the data via the CLI, I know its there and I could copy it via SFTP but would like to see why an SMB share continues to fail.

Use the “Strip ACL” option and reset the permissions on the dataset to what you want them to be.

I tried that and it failed. I did figure it out though. When I changed the permissions on the pool itself titled storage via the CLI to 777 the share began working. Since the original pool was created with Freenas I thought it may have only been accessible by root. That seemed to be the issue and everything worked after that. Thank you.

1 Like