TrueNAS hates me

I have asked this in a few different locations and seem to be on an island, this forum has been one of the best places to find like minded nerds.

I have an old BackBlaze unit that had a PSU issue and the old controller cards it came with stopped working. I had an HBA 9305-16i sitting on a shelf and put it in, its only reading one HDD from each 5 port backplate, was told to make sure its in IT mode by someone in the TrueNAS discord. It is in IT mode so that wash.

Did some reading and everyone said that the SAS9211-8I 8PORT Int 6GB Sata+SAS is the better way to go. That’s having the same issue, but its in IR mode. I am getting a PAL error when trying to flash it, so people say just set it to UEFI mode. Well I cannot seem to get that to work, I have tried to do that UEFI mode a few times and not sure why its not working. Following this guide Detailed newcomers' guide to crossflashing LSI 9211/9300/9305/9311/9400/94xx HBA and variants | TrueNAS Community

So here’s my real question, does the 9211 or the 9305 really support sata port multiplier and I am just painting myself in to a corner? also if they support it why is the 9305 being a hater? and How can I get this stupid 9211 in IT mode when UEFI is not working? Or how does one UEFI mode? lol

It seems most guides skip basic steps and I cannot figure this out. I am loosing sleep because my head will not let this rest. I really could have bought a new system at this point. Hell the only thing that is the same on it is the backplates, CPU and Case. Everything else I have swapped out trying to get it working.

Please Tech Lords help me.

I once had to flash a SAS9211-8I myself and I remember asking similar questions. I believe I was able to flash it successfully by using FreeDOS created by Rufus just like this article explains. I remember having issues with UEFI and my motherboard.

A quick Google search brought me here. Have you tried these suggestions?

I have reviewed both of those a few times over the last few days, I was able to get into the FreeDos just fine vs Rufus thats how I get tot he PAL error, when I try to hit sas2flash.efi from the USB it does nothing.

Not sure why that is, but maybe I dont look for an all in guide maybe just looking for step one. UEFI FreeDOS boot disk?

I’m sorry man I wish I could help but I’m not sure. I used an ancient board that didn’t support UEFI combined with FreeDOS from rufus.

In that second link the last comment says they were able to use Windows 10 recovery to then get to a UEFI prompt. I’d try that route if you don’t have another board.

That might be a good idea love it, thanks will give it a try in the am.

Its been a long week with work and just getting back to trying this.

Did a windows boot disk like it said set BiOS to UEFI mode only, set myself to the dir of the USB ran sas2flash.efi (any command they have)

I get “No such interface supported”

So I guess I have some more reading to do lol

I flashed one of these critters about 2-3 years ago, and I remember it was a pain in the ass. Of course I didn’t write it down, as I never planned on getting another one. So I don’t remember exactly what I did to make it work unfortunately.

I know this site I had looked at, can’t remember if this one worked for me or not though.

Thanks, looking into it now.

lol so…

ubuntu:~$ sudo apt-get install refind
Reading package lists… Done
Building dependency tree
Reading state information… Done
refind is already the newest version (0.11.2-1).
The following packages were automatically installed and are no longer required:
libllvm7 libllvm9 linux-hwe-5.4-headers-5.4.0-45 linux-hwe-5.4-headers-5.4.0-52 linux-hwe-5.4-headers-5.4.0-53 linux-hwe-5.4-headers-5.4.0-58
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 57 not upgraded.
ubuntu:~$ refind install --usedefault /dev/sdb1 --alldrivers

Command ‘refind’ not found, did you mean:

command ‘refine’ from deb argyll
command ‘rdfind’ from deb rdfind
command ‘rebind’ from deb websockify
command ‘remind’ from deb remind

Try: sudo apt install

ubuntu:~$ sudo refind install --usedefault /dev/sdb1 --alldrivers
sudo: refind: command not found

Update: I tried to make a UEFI boot with this shell

it is just loading a black page, something I am missing but getting closer

I was able to get the card into IT mode it still did not work, had to remove boot disk for the MB shell to load.

Still having issues with it crashing via some middleware issue, I posted on the Truenas reddit and no love yet. Just wanted to make sure I updated here.