[TrueNAS Core] Specifying Web Interface IPv4 Address: All Interfaces Not Showing?

EDIT: [Solved] I apologize; I searched poorly. Tom noted here ( Bind IP not showing up on TrueNAS ) that in order to set an interface as a management IP, it needs to be static, not DHCP.


I’m setting up my first TrueNAS Core instance; it’s going well so far.

That said, I’ve run into an odd issue. I’m trying to get the TrueNAS GUI to only be accessible via my management VLAN. I don’t want any member of any other VLAN to be able to access the management GUI, including members of the storage VLAN (plenty of devices will need to be able to access the NAS via the storage VLAN that have no business being able to see or change the server config.)

I have two interfaces working on IPv4. IPv6 is disabled entirely on my network for Reasons.

  • em0: An onboard 1 Gbps RJ-45 on motherboard of the Dell Optiplex 5040, attached to an access port on a switch set to my Management VLAN (e.g., VLAN 50).
  • lagg0: A pair of LACP’d SFP+ ports on a Mellanox Connect-X3, attached to the same switch on a Storage VLAN (e.g., VLAN 60).

Everything is responding to ping as expected, and right now the web GUI is accessible on both interfaces. In Network → Summary, both network interfaces show up with the IP I assigned them via static DHCP reservation in OPNSense.

My issue arose when I tried to bind the web GUI to the IP associated with em0.

In System → General → GUI, I have an option for Web Interface IPv4 Address. It’s showing me two options: (all interfaces) and (the VLAN 60 address).

I don’t have an option to bind to the VLAN 50 address, even though that’s the one I’m using to access the web GUI, so I know it works.

I’m not sure what I’ve done wrong. I did notice this help text on the interface binding dropdown menu:

Choose a recent IP address to limit the usage when accessing the administrative GUI. The built-in HTTP server binds to the wildcard address of (any address) and issues an alert if the specified address becomes unavailable.

It’s like it’s not counting the management VLAN address as a “recent” address. Not sure what to make of that since I’m using it. ¯_(ツ)_/¯

I’d appreciate any advice. Thanks! :slight_smile: