TrueNas Core shadow copies issues

I just upgraded from 11.3 U4 to 12.0 RC1 and now my windows pervious versions don’t show any.

I had shadow copies set up on FreeNAS 11 before and they worked. Since the upgrade they seam to have disappeared. I tried to delete the old snap shots and create new ones but when I go to advanced and enable shadow copies there is no drop down anymore to point them to the snapshot location. I tried to un-enable SMB and then re-enable it and still no luck.

Do I have to delete the shares and re-create them?
I did upgrade my pools to 12.

I am in almost the exact same boat. Previously working perfect on 11.3.
The only difference in my case one dataset works, but none of the rest do.
My snapshots are a single recursive task at the top level of the pool.

I also upgraded my pools deleted the old snapshots and more or less started over.

Did you happen to figure out what was going on in your case?

I ended up deleting the shares keeping the snap shots going and turning off and back on the SMB service and they are working now.