Truenas - add user permission change

Was watching the step by step

There seems to be a permissions change in TrueNas Scale when adding a user on a fresh install version

Following the steps in the video (timestamp 2:00) you add the u/n, password scroll to the bottom and click save.
When I do that the “Home Directory Permissions” are not correct & I can’t change them for the “/nonexistent” default. This version sets them to:

User: Read/Write/Execute
Group: (all unchecked)
Other: (all unchecked)

Everything else is the same as in the video. Do I need to do anything? I’m second guessing because it’s a non existent directory so how can u set permissions but then how/why does the “User” have them set.

If you are not setting a home directory then those don’t really matter.

1 Like

Ahh thanks. BTW in one of your videos (maybe this one) you rebooted the machine because…well windows hangs onto the old connection. I use "net use /delete <share/dir>
That way I don’t have to reboot. Hope my tiny contribution saves u some time :slight_smile: