Truenas 2FA Not Working

We are attempting to set up 2FA on TrueNas using Bitwardan and the authenticator. For some reason, we are not able to get it to use. We have attempted to set it up using both the QR code and manually entering the secret. For some reason, the code is not accepted and we need to disable 2FA via SSH to get back in.

Has anyone else had this issue? Any thoughts on a resolution?

Most likely the time is off just a bit on the TrueNAS system. Under the 2FA settings you can set the “Windows” to 1 which allows for the TOTP to either be the one before or after the current one.

Thanks. This turned out to be the issue. We run an NTP server so I did not think of even checking this. The time had drifted about 15 second. Upon further investigation I discovered the NTP service was not running. Corrected this, updated the time, and all is good. Thanks again.

1 Like