Trouble understanding OpenVPN (For remote)


I watched Tom’s video on how to set up an OpenVPN server so that I can connect to my network from the outside. I followed everything but I am getting some problems that I do not understand. I tested this on a Windows VM that I have on my network, it connects to the server but I can’t reach out to the internet. For the sake of typing so much, I am going to post screenshots of what I have set up.

Dashboard errors:

VPN Server Settings:

Client settings:

I am trying to get more comfortable dealing with and configuring VPN settings. I just can’t seem to get this to work. I don’t quite understand the settings above that I shared. My home network is the subnet, I created a random subnet for the virtual network that is the middle man for this setup. Can someone please help me better understand this?

Thanks so much!


On your RAS setting you can enter the local networks IP range to access them, see the IPv6 that option is available. I think one of the check boxes will display them.

The other way to address the same thing is through your rules.

1 Like

That’s the one. I have it checked myself and use the rules to define what the client can access on my network.

1 Like
1 Like

Can you dumb that down a little for me? I just want to be able to access my from outside. I don’t use IPv6 on my home network, at least not just yet.

So let me explain how I see these settings. Obviously, is the network that the server is on, the next address would be the server The network network is in the middle of the two to pass through the traffic?

The settings tunnel network and remote networks are the ones I’m getting confused over.

Yes, this is the video I was using. If I remember correctly, I didn’t see how to set up the client stuff. I think that is where I started getting lost.

In @neogrid screenshot you can either force all traffic over the tunnel by checking “redirect ipv4 gateway” or if you want to only access specific networks then you will leave “redirect ipv4 gateway” unchecked and specify your LAN at under “ipv4 local networks”

Maybe the best way to think of it is when you setup the RAS server, you needed to create a new interface and there will be a new rules section also created. So now you would need to create the rules between your RAS and LAN network, I find that easier to manage. Then any client dialing in will be only able to do what the rules allow it (in this case have that box checked).

Not totally sure what happens, if you have not entered anything into your rules but enter the LAN into your Remote Network on the RAS config page, but it probably ought to provide you access to your LAN.

It’s basically the same principle as adding vlans, a new network is created and you use the rules to decide how it should work with the LAN.

@drinkyT I think what you might be missing are DNS settings. When you use the full tunnel option “Force all client-generated IPv4 traffic through the tunnel” it may also require you to specify DNS servers in the OpenVPN server settings. You could do something like this and see if that works for you:

1 Like

Sorry for the late reply, I will definitely give this a shot. I will let you know what I find out, thank you so much!!