The host toolstack is still initialising. Please wait. - unable to do anything

I have three xcp-ng hosts in an xcp-ng pool. I applied updates on all three hosts but only restarted the first two hosts, xcp-ng-03 was set to the master before I restarted the two other servers. Once they restarted, they have been stuck in maintenance mode. When I log into each server, it shows no nics present (I have two) but I am able to ping all of the IPs. I have restarted the hosts and when I run xe task-list, I get the following: “The host toolstack is still initialising. Please wait.”

I am currently running some live VMs on xcp-ng-03, so I haven’t restarted this server because I am using these VMs for my infrastructure. I have tried to detach 01 and 02 from the pool but get an error as well. When I look at the Storage and Network, everything shows connected in XO. I also restarted my Synology Server which provides NFS and iSO storage.

Is there something else I can try?


Have you tried to emergency reset the NICs from the console?

Yes, I tried those. I backed up my existing VMs and restarted 03 and the other two hosts came back online. Thanks

The sequence for updates is:

Apply and reboot to pool master first.

Apply and reboot to any other host and continue until all host are updated.

Often I find that I may need to reboot XO after having the hypervisors off for a little while, I also run my XO as a separate PC on an old computer. To me it just makes sense. but I do also install XO as a VM for backup. Just backup and restore the config file to replicate accounts and passwords to each additional XO.