Synology rsync to Truenas Scale SMB share problem

In 23.10 Truenas scale rsync was deprecated and I realized it after my backups from synology to my truenas showed errors (I just updated about 2 weeks ago)

I saw a video from Tom Lawrence, thank you Tom, on how to set it up as an app. That worked.

This is my problem for which I have not found a solution: I like to use rsync from my Synology to my truenas (remote) and be able to read the files in an smb share.

I have this set up on my test truenas VM:
Where photos is a dataset with an SMB share

Synology indicates the following error:
“Insufficient Privileges to access this destination shared folder. Please contact the destination administrator for assistance.”

I note that I added user: photo55 with password: Thisisjustatest55

On the dataset rsync_master, which was apps type, I added user apps with full control and also user photo55 with full control. I then did the same thing with the photos data set but this dataset was an SMB dataset and then I added a share which I thought would allow me to send the files there and view them with a file browser.

I can get this to work:

But when I send files to my truenas, since it is not an SMB share I can’t just use a file browser to inspect files.

I am doing something wrong or I am missing something. Can anyone guide me please or send me to the right documentation?

This is my project now since I have tried to get syncthing to work on my synology NAS either as docker or the community app to send files to my truenas for months and I have given up for now. I have not been able to get it work and most people seem to have it working but I have not figured it out.

I hope I am not doing anything crazy by posting in both truenas forums and Tom’s forums to see if I can get some help.