Synology locking out hardware

Currently, run 2 Synology NAS for home lab and cameras. No complaints they have worked great for everything.

We were replacing an old NAS at work and decided to go with the RS3617xs because it had the drives we used on its compatibility list. Our vendor quoted us the unit and we started the order. Apparently, those are now discontinued and our order was upgraded to the newer RS3621xs. That unit has maybe 10 drives on its compatibility list, 6 of which are Synology’s own drives.

I went to set up the unit today with our current WD Red 8TB NAS drives and they ended up showing up as incompatible. Not a big deal, this unit is being used as an alternate site archive for which there are many others, and worst-case scenario if data went bad due to some rare unforeseen drive compatibility issue then, it could be recovered from an alternate site. So I went to create a Storage Pool, but the create button was greyed out. When I checked the HDD/SSD tab it only showed two drives initialized and 8 others were showing not. I called Synology, their rep told me if the drives aren’t on the compatibility list for that model, they would not initialize properly. Two of the drives only initialized because they were used to install DSM.

So basically they seem to be locking out drives that aren’t listed as compatible now. Drives I bought for my two home units definitely weren’t on their compatible list, but they showed up and worked great. I found this Reddit post where apparently it’s a new decision made by their current management. One that isn’t to popular with most Synology fans and I can understand why.

Any of you guys ran into this experience with this or other models? If so anyone found a way around it?

Only those specific models have that feature Synology Launches Enterprise Hard Drive Line and Starts Locking Drives for New NASes

1 Like

Thanks for the info, Tom. That’s good to know. I think we are going to try and get the 18 model if they still selling it. So frustrating they are starting to do that now. :frowning:

Sounds like you need to return it and thank the vender for trying to help by updating it to the newer version. Then, as you say, try and get one of the others that isn’t so locked down.

I use HP servers and often find similar strange “one drive works but another identical one does not” or “this drive works in slot 3 but not in slot 5” kinda problems. Never happens with the official HP drives though…

Definitely. Working with the vendor and they are going to take it back and try to get the 2018 model of the same series if they haven’t discontinued it yet. :slight_smile: But yeah, hate the vendor tried to do something nice, and then that happened. But live and learn. Awesome to have a resource like you guys that have an ear to the news on these things. I’m going to have to watch STH more often now. :slight_smile: