Syncthing on TrueNAS Scale - increase inotify limits

I am running Syncthing between my Windows PC and my TrueNAS Scale server, I keep getting an error message that basically means I have too many files to for the default “inotify limits” Usually 8192, and Syncthing gives me some command line to solutions resolve it.
I am a noob to ubuntu and not entirely sure I understand the method.
On many Linux distributions you can run the following to fix it:

echo “fs.inotify.max_user_watches=204800” | sudo tee -a /etc/sysctl.conf

It that to be ran in CLI or the Linux shell ?
Does the /etc/sysctl.conf refer to the default Syncthing directory?
As Recommended by Tom I have installed the Syncthing in “Pool/My_App_Data/Syncthing” folder (not /etc/)

I just need some clarification so I don’t destroy my very happy NAS please. (other than this issue that is)

Thank You

Not something I have every tried changing in TrueNAS Scale and because it works in a docker container not sure where it need to be applied. There is a post in their forums about it, maybe bump it or start a new one. SCALE | Syncthing inotify Limits | TrueNAS Community

Thanks for the reply Tom … I simply set it up the way you suggested in your you tube video: “How To Setup TrueNAS Scale Apps With Shares For Host Path Volumes” I didn’t realize that was putting it in a “docker” The link that Syncthing directs is “FAQ — Syncthing documentation”.
I think it is a Ubuntu issue and the command line to increase the limits will work. I just need to be sure how to deploy the command.
Thank you.
Your videos and information have enabled and encouraged me to have a go, and I’m loving it!

Ok so I undrstand … A little more .The link you gave me I didn’t fully understand at first, sorry for the noobie-ness. I see the post where qmbc2YR posted. That is what I need to do .But how did he make the changes?
SystemSettings → Advanced-> Sysctl
fs.inotify.max_user_watches 524288 true Increase inotify limit

Yep … Thats what I need to do!!

1 Like