SuperMicro and Dell?

I’m building my new custom pfsense appliance and have come to a snag. my SuperMicro Motherboard A2SDi-4C-HLN4F doesn’t seem to like my Dell 0HM9JY Quad Port PCI-E NIC. After connecting the Dell to the SuperMicro Riser card RSC-RR1U-E8, I get a solid green activity light but no link light whatsoever.

Any clues as to what’s the issue? I’ve even checked the bios and it’s not showing up there as well, though the riser card is showing up.

You might see if your bios is up to date on the server first. Then I would try a different NIC if you happen to have one laying around or if you have another computer to test your quad card in to see if that works.

I didn’t think of that Lol, I still have my old pfsense box, imma check the card right now and get back with you. Thanks.

Just tried the card in my old box and it works in it. And the bios time was off in the Supermicro just set it to the right time. So should I just retry the card again now that the time has been corrected?

Reiterating your first post to make sure I understand.
Supermicro Mobo & Dell Card work fine together
Supermicro Mobo, Riser, & Dell card do not work

If this is the case, I would suspect a bad riser card. Can you try other PCIe cards with it?

1 Like

I just tried the card without the riser and with the riser and made sure bios time and date are correct but still no link light but I do get a solid green activity light.

Bios and firmware are both up to date also.

I’ve had intermittent issues with brand name / none brand name hardware. I use HP servers and always spec HP branded NIC’s as I’ve had issues even with Intel branded cards.

Is your old pfSense box a dell by any chance?

I think (but have never really got as far as checking) that the branded ones have a slightly different pciid and that causes issues.

You could boot the box from a linux live usb stick and see if lspci finds it. That would at least give an indication if your problem is hardware or driver related.

Sorry, missed that bit. I doubt it will show up in lspci if the bios doesn’t see it…
Does it show up in the bios if you drop it straight in without the riser as @brwainer suggested?

Doesn’t show up even dropping it straight on the motherboard as well.

I’m pretty sure that’s the same card I recently put in my pfsense box, I have the older SuperMicro A1 board, everything is working fine for me. That said, I’m still on an older version of pfsense, going to upgrade to current in a couple of weeks so maybe I have a surprise waiting for me.

Have you checked to make sure, I have 8 NICs showing in my pfsense, with the card becoming the first 4 and the on board the second 4. That part threw me for a little bit, but I was getting link lights before I figured that out.

Do you have any other cards you can try in the computer to make sure that the PCIe slot is working?

Also have you tried booting the computer to a linux live disk and seeing what works?

I will say that a newer card might be better, mine does not fully support all forms of offloading, so while it was an upgrade from the onboard NICs, it isn’t exactly where I want to be. I think I really want an Intel i35x card installed and just need to find one at a good price. I may swap the card in my firewall at home as it’s a slightly newer version and no offloading issues, I only need 2 ports at home (unless I get a Starlink beta unit, might want 3 then).

Update y’all, I finally got my Dell AOC to work. I was looking around in the bios settings under Advance and I found a setting call Flex I/O and switched the settings to PCI E 4/Sata and rebooted the server and bingo my card is now up and running.


Good news, well spotted.