Strange errors with Robocopy across VLANs

Hey all,

I have pfSense setup as a firewall with VLANs setup using my Ubiquiti switches and the ubiquiti controller. I am having issues with doing robocopies across VLANs.

I am receiving the following errors:

The network is busy. ERROR 54 (0x00000036)
The handle is invalid. ERROR 6 (0x00000006)
An unexpected network error occurred. ERROR 59 (0x0000003B)

I was able to backup the data by switching to the same VLAN but I am stumped.

I am not sure if the behaviour is just part and parcel to VLANs and Robocopy or if I have a configuration issue, or if it’s a bug with pfsense (latest) or Ubiquiti’s controller v6.5.55 or my QNAP

Has anyone else experienced this?

I had a folder in there that was showing up in samba shares as an alphanumeric string with a ~ in it but in the qnap browser it was showing up fine. Though it was missing the files I needed to transfer. Super odd…

I’m making another ticket with QNAP

QNAP is being unhelpful since the robocopy transfer works across the same VLAN.
This is my first network that utilizes VLANs.

It seems like an issue with long filenames and can be solved with QNAP setting.


Does it work if you accept all traffic between the two VLANS? If so, find out which ports are failing etc.

These VLANs were not filtering traffic for eachother. It was a red herring support picked up on.
Eventually the ticket got solved. Always confirm your backups.

I switched to TrueNAS.