SSH pfsense putty with port


Trying to SSH into pfsense. Not sure how to with a port. is the web ui but not sure how to get to it by SSH using putty

Ok…so my edit here is I think I messed this up.

my web ui went to: (example) now I changed the SSH to port 1111

now I can’t get to the web ui.

if I SSH I can log in and can type viconfig but I don’t know how to change the port on the SSH and save to get the web ui back?

How do I do that?

By default, ssh listens on port 22.

To reset, try this:

Do you know how I get to that screen? and what are my steps? This screen is where I can get to


Did you install the SSH tools in pfsense.


I did. I realized yesterday that I can log in as root. That got me to the option screen.

So I tried that option and I still didn’t get in. I then tried option 15 and rebooted and that worked for me.

I know better now. Boy oh boy… That’s what ya get for thinking sometimes. Lol

Thank you for your help.

You should be able to SSH into port 22, but I don’t remember if I had to open that port.

I can now. My thoughts were that the SSH port had to be the firewall port I was using. That “apparently” was not right. LOL

Making that match locked me out of the web ui.

Good thing I could get to the screen. I was getting nervous.

The more I have been using pfsense I am really liking how things are easier to fix and recover from. Glad we found Lawrence systems. And you here are very supportive. It is awesome to see!

The firewall port you are thinking of is just an http/https port. By default, HTTP is port 80 and HTTPS is port 443. SSH by default is port 22. SSH is not HTTPS, so you cannot ssh to port 443.

1 Like

Enable or configure ssh server & port from the GUI: System > Advanced , Admin Access tab.