SR doesnt find VDIs when re-attached [xcp-ng | xenserver]

I recently removed and reattached a NFS SR because it was acting weird for some reason, and this time when it reattached it was unable to find any of the VDIs within it. I tried vdi-introduce through cli but that didnt work. And I cant really find more information on it. I dont know if theres anyway to see why it cant find them or force it to use them.

Do the files still exist on the NFS server?

Hi Tom,

Super stoked to actually have you reply (as i sit here wearing one of your hoodies). I think I might have solved it myself after a good 5 hours of reading forums and almost ready to accept that all the data was gone. rip no backups. My lack of knowledge of how all the parts of XCP-NG work is what lead me to believe that VDIs were the issue. When I reattached the SR I did not understand what the reattach SR button did and thought all the UUIDs list were the disks and not the storage UUID. A search for “convert VDI to VHD” is what tipped me off on the solution. The folders in the NFS mount point are SRs and not VDIs. ls -lh showed me a REALLY big folder and inside? VHD!!! Due to my trouble shooting steps I was unable to reattach the SR because clearly active hosts were “Offline” for some reason. So now im in the process of importing the VHDs and booting them to see what VM they belong to.

TL;DR, I didnt know what I was doing and now I have to manually upload and rename VHDs by arbitrary UUIDs


1 Like

Glad to hear you have a solution :slight_smile: