Sr_backend_failure 109

One of my XCP-ng VM’s suddenly refuses to backup (XOA BackupNG Deltabackup).
It always returns “SR_BACKEND_FAILURE_109(, The snapshot chain is too long, )”
I read on forums that this has something to do with too many snapshots, but when I check there are only 3.
I also can’t mannually create a new snapshot anymore …
I even tried to delete 1 of the 3 existing snapshots, and then tried to manually create a new snapshot, but no luck either …

How do I “clean up” the snapshots on this VM to free it up to make new snapshots again ?

How do I set Backup-NG not to encounter this problem again in the future ?

Probably too many snapshots and not enough time to coalesce.

yes, that’s what I thought, so I stopped the backups for a few days to let it “resolve” itself … now 3 days later the problem still hasen’t gone away … so it looks like it’s not that … or is it ?

FYI the snapshots/backups were scheduled every 15 minutes …

As I understand it, the speed of the coalesce process depends on the disk IO activity combined with the speed of the machine. Also, if there is enough freespace to perform the action. There are more in depth discussion on the XCP-NG forums.

the VM has a lot of orphaned VDI’s

I try to remove these in XCP-ng center 8.0, but I can’t : “Error in Metadata volume operation for SR”

can I fix this ?

If you run “xe sr-scan” are any errors reported?