[Solved] XCP-NG not detecting Drives during install

This is my fourth time overall trying to install XCP-Ng.

Everytime I tried installing, somehow XCP-Ng doesn’t detect my drive. I tried on three different system (in last six month) so far and they are all different in specs. Even different boot drive I am trying to use - WD, samsung, Kingston, Crucial.

One of them was R730xd, another custom build intel i7-12700 and NOW dell 3060 sff pc. Finally I am tired and I really want to try xcp-ng.

If I try booting any other system, it can see such as proxmox, debian, even windows, but when I try xcp-ng, it doesn’t see it.

Here is screenshot of different OS on dell 3060.

This is during XCP-NG install:

BIOS settings:

During Proxmox Install:

During Debian 11 Install:

During Window 10 Install:

How do I solve issue?

Not really clear as to why, make sure you are using the latest version and try turning off UEFI and us legacy mode.

I am using latest version and I did turn off UEFI and did you legacy mode. No luck.

It is stupid. At that screen, I had to just continue instead of try to load. All good. Thanks.