[SOLVED] 5G Home Internet


I was hoping someone can point me in the right direction? I have a 5G home internet device that has two LAN ports. I want to connect my firewalls WAN to one of those LAN ports and treat the 5G device like a modem. When I plug the firewall in, I get an IP and a gateway IP, but it drops and connects repeatedly. I don’t know what I am looking for next to solve this problem. What should I be searching for to help me solve this problem? I tried searches like changing the WAN port into a LAN port, but I don’t think it is possible and I am not sure if that is where I should be looking.

Any guidance would be greatly appreciated

there’s no configuration needed if you are using 5G Home Internet, just take one of the cable and plugin to the firewall, there’s no need to set bridge mode and i don’t think the 5G home will let you anywyays.


When I plug in the firewall into the 5g device I get an IP and gateway, but it drops repeatedly. I get no network. I was wondering why/how this is happening and how I can fix it.

which 5G Home Internet Do you have. my 5G Home Network works fine with pfsense. I have Verizon 5G Home and the only thing i did was just add the cable from the unit to the pfsense device and i’ve been running fine since like a month.

I have t-mobile 5G home internet. I wonder if it is something to do with T mobile then. Unfortunately I’m not network savvy so this will take me a little bit to figure out.

Try connecting another device like a laptop via a cable and see if that drops the connection, too. Also check connection via WiFi. The device you got from T-Mobile is a router itself, not just a modem. DHCP on the LAN side should work regardless of the 5G WAN connection. If your wired connection keeps dropping (i.e. the link goes down on your firewall’s interface), this might be due to a faulty cable or port. Try other combinations of ports and cables.

What firewall are you using? My pfsense constantly drops enough pings that it says offline, but the internet is really still there. I have Tmobile too.

The only fix I can find, is to increase signal strength by using external antennae, I have not completed this step yet so still a theory. I did get some improvement by buying my own device, this is technically not supported for Tmobile home so not sure I should discuss it. I bought this device Quectel CAT19-RM520N-GL Wi-Fi 6 Industrial LTE 5G NR Wireless Modem Router Bundle Fixed Wirele – Chester Tech Repairs I have the Mediatek version, not sure if the Qualcomm is better. The external antennae have helped a little but I think I still need something outside my house to fix things. I have great LTE coverage but my 5G is fringe right now.

Apparently you can get “bring your own device” with the business plan, but their rules are funny about who can get the business plans (same cost and same performance).

If the suggestions for directly connecting to the modem show that you are still really dropping internet, then signal is too low or their are working on the towers. Move the modem around to improve the signal strength if it is low signal. You can also call support, you will need the device’s phone number for this. Every time I call they are really helpful and sometime they can sort out issues with the tower that you are assigned to use. Yes towers are soft locked and the end user has no way to force them to change.

And yes it really is a phone. You can send it text messages, but voice calls are blocked. The lack of text messages with my new modem is less than ideal, it is nice to be able to look at the messages and make sure my payment went through like it is supposed to do automatically. This is the first month with my new modem so still trying to figure stuff out. Also getting ready to but a small antenna mast on the house and I’ll eventually get some directional antennae (either a 4x4 mimo flat panel or four yagi). I need to ask the guy at Chest Tech. an question about finding 5G tower id and see which tower I’m connected to, I can find the LTE tower with the commands presented on his site.

So I have the matter resolved. After plugging in the 5G “modem” if you will, into the pfsense firewall I had to reboot the firewall. That resolved the dropping issue. Another issue after that was pfblocker, something about it wasn’t allowing me to make a connection to the outside world. There is a default configuration called PRI1 under pfBlockerNG > IP > IPv4. I had to deactivate two of the IPv4 Source Definitions (CINS_army and ET_Block) and now everything is working.

dpinger is not showing a bunch of dropped packets or showing “offline”? After a reboot my dpinger starts normally but after a few seconds I’m dropping enough packets that it reports offline. My 5g normally reports as “weak”.

Just got a reply back about the tower stuff so I may order an antenna kit soon.