Slow WAN through pfSense


I know there are plenty of discussions on this elsewhere on the internet as well as here in this forum. From what I gathered though, my setup is different as I have not virtualised my pfSense instance but I have a dedicated PC running the OS.

pfSense CE is my direct interface to the internet. It is installed on a mini atx PC (Gigabyte MN525RI motherboard) with 2x Intel gigabit onboard lan ports. The pfSense install hardly makes a dent; CPU loading sits at 5% and memory at 14%.

On the lan side, pfSense acts as the DHCP server and is connected to a Ubiquity flex mini 5 port gigabit switch for hard wired access. One port is also used by a Ubiquity Unify 6 LR AP for Wifi. I have about 25 clients connected on Wifi, most of which are IoT devices which are not utilizing a lot of bandwidth. I only have one hard wire client running Home-Assistant OS.

My internet speed on both ethernet and Wifi is extremely slow. Latency is noticeable but so is the speed, especially during working hours with my wife and I both in online meetings. gives me around 20Mb/s through pfSense and without pfSense I get my paid speed of 100Mb/s almost exactly. PfBlockerNG does not make a difference if it is on or off. There also is no traffic shaping or bandwidth limiting set up.

I need assistance to troubleshoot this. I am an amateur with a functional/conceptual understanding of networking, I am by no means an expert. I use pfSense mostly for my own interest but also because I test IoT devices for proof of concept studies for my employer.

Any assistance and guidance to troubleshoot this would really be great.

Thank you

My pfSense is Protectli Vault (J1800, 8GB ram). I don’t have 25 wifi clients but when I measure the wired connections using I get the same speed that my ISP says (180/10). My pfSense is stock, no addons.

Have you check if the offloading on your NIC card is disabled? If you go to System\Advanced\Networking. At the bottom page you will find Network interfaces. Make sure none are checked.


What brand of NIC do you have? Pfsense works best with Intel cards…if you are using a Realtec card that could be the issue. You can find dual port Intel cards for $25 or less…


Thank you for your reply. I disabled checksum in any case but the onboard ports are both Intel:

1x 82574L and 1x 82567LM. Both 10/100/1000 Mbps

Thank you. That is great. Do you have any idea what could be different with my installation which is also stock?


Thank you, they were all checked, I have unchecked and restarted now and it worked perfectly! Thank you :ok_hand:t2:

the hardware checksum offloading is unchecked as raymond070605 wrote.