Slow search on a Synology mapped network drive

Hi, Everyone.

Can you help me on a problem we are encountering, I have friend who has Synology 220j. He configured the shared folder to be mounted on 2 of his computers. Originally the 220j was running DSM 6.x and the search was working fine. We then upgraded the DSM version to 7.x and perform indexing in Universal search of DSM, thinking it will make the search faster. Unfortunately it did the reverse, now using Windows Explorer if we search a file in the mapped drive, it takes a while to return a search.

My friends network setup is pretty simple, both NAS and computer are connected to an ISP modem/router. The computers are wireless connected to the modem/router, I was thinking to ask him to connect a cable to an of the computer and see if there will be improvement. I have also tried setting up Synology Drive and configuring Teams folder, because he didn’t like it because it download a copy into his computer, he wants to run the autocadd files from the NAS

Do you guys have any advice that we can try to configure either on the PC or on DSM?

Are you using NFS or SMB? Have you tried to recreate the share after the upgrade?

This is a Samba share. The client machines are both Windows 10.

In regards to recreating the share, what do you mean? Removing the mapped network drive and then recreating the mapped network drive or totally deleting the share and creating a new share?

Maybe both just for troubleshooting steps.

Thanks for that suggestion, it worked.