Sftpgo and pfsense

PARTLY SOLVED: Embaressing. I obviously have not understand how to make changes in the pfsense NAT / Rules take hold. I though it was enough to save but I had to restart??? The HAPROXY question remains!

Hi. I have several TrueNas Scale file servers with the need to share files and data with friends, partners and family. Until now I have used a ftp server on windows server 2019 due to the availability of Virtual Folders and the use of the full AD system in my domain (AD controller on WIndows Server 2019). It is hovewer very slow so I am looking for alternatives and have decided to test the sftpgo server which I have implemented on a VM Linux Mint 21.1. The server workes fine on my internal network but I am not able to contact it through pfsense. I have only tried portforwarding. In the documentation of sftpgo its stated that it supports haproxy and this i can not understand (ssh based protocol). It would ofcourse be great to be able to use haproxy…

sftpgo has a very good functionality as it supports virtual directories, authorisation system ++++

Anyone having any idea or suggestions on how to get sftpgo through pfsense and or use haproxy for it? Even suggestion on other fast up/down load servers would be welcom (preferably for LInux implementation)