Setting up UniProtect System

Hi Guys/Gals,

I had this issue recently where my CloudKey Gen 2 Plus (installed in it’s rack mount device) failed to boot.
This was unexpected and i didnt know how to fix it.
I have about 6 cameras and a Unifi Doorbell connected to it.
After posting on the Unifi forums someone told me how to use the reset button and get into recovery mode, and reset to factory default.
Now it’s on a different IP address and none of my cameras are connected to it.
I am trying to work out how the heck to connect all the cameras (and doorbell) again as i have no idea how to do it?
The first time i set everything up, the CloudKey just picked up the cameras and i added them via the app on my phone.
Now it’s not even finding them when i do a search.
I dont really know where to start.
What ive tried doing is turning off the whole network and letting everything power down and restart again but that didnt make the cloudkey find any of the cameras
The doorbell still works in the way of the chimebox dinging when someone presses the doorbell but it also is not appearing on the network now.
Currently i am trying to update the software for the Unifi Protect app that i get to by typing in the IP address for the Cloudkey through my browser. This used to be the way that i would check all the cameras and view any activity etc on them.
I am guessing it needed an update because i went to factory settings.
Any help will be very welcome!
thanks in advance

I just had this thought… do i need to go to each individual camera, and do the factory reset on them each individually?

If so, i can do that. but how do you factory reset the doorbell?


The quickest way would have been to reset the cloud key and restore the backups. If you don’t have any backups then you will have to either log into each device and adopt them to the cloud key or reset each device.

Thanks LTS_Tom!

I’ve tried taht with the first one (resetting the device on the device itself) and it worked! so i have one of them back on the network already. Will do the rest tmw!

Do you know how i reset the doorbell?


¯_(ツ)_/¯ Never tried, but I am sure google can help you find the button.

Hi again Tom,

sorry to bother but i haven’t solved this problem completely yet. i had a couple of the cameras reset and back onto the network, and now i cant even log into the Unifi protect via the browswer as it says taht it’s not on. But the cloudkey is running and i can see the IP address.

The thing i have noted, is that it’s got its light going solid blue and then after a while it flashes white.
Im not sure this is the normal status of it when it’s operating properly?

So i haven’t been able to get my UnifiProtect stuff up and running again.

I also noticed in the Unifi Network (on browswer) that two of my mini flex switches are also not connected to the network, and the devices plugged into them stopped running so that’s how i initially picked up on that problem too.

Do i need to do an entire network rebuild or something?

I’ve got everything running from the POE 16 port Ubiquiti switch.

any advice will be helpful, i had this all up and running for about a year before the cloudkey just came up with an error and wouldnt boot and i had to do the factory reset on the device and put the 1.x.x firmware back on to get it to work again.

Then i got 2 of the cameras back on by using their reset buttons (on the cameras) but now as i explained above, i can’t even connect to UnifiProtect because it says it’s down, but im going to the right IP address.


If you can’t get to UniFi protect then you will probably need to reset the cloud key.

ok i’ll try that first.