Screenconnect Black Screen when connecting to Windows 11

Has anyone experienced a problem with a blank black screen when connnecting to a Win 11 Pro box?
I’ve been telling all my customers to stick with Win 10 for the moment but I decided this week to setup my first Win 11 box and ‘try’ and use Screenconnect to connect to it.

I install the agent on the Win11 box and then try and remote in from my PoP os machine. I just get a blank black screen. I’ve also tried to connect to it from a Win 10 vm and get the same result. The interesting thing is, if I am logged into the Windows 11 computer and try to connect to it by right clicking on the machine in the console and select the ‘join with options’, it gives me the following screen

If I select the ‘test’ user and click ‘join session’ it allows me to connect. This won’t work for me because I use this service to connect when the computer is ‘unattended’ and when the user leaves their computer they either log out or lock their screens.

Connecting from a Win 10 machine over RDP works fine everytime.

Connectwise support are saying that I will need a ‘senior’ engineer but still waiting to hear from said ‘senior’ engineer.

I’m just wondering if anyone else has come across this problem?


Just an update, in case anyone else encounters the same problem.
It boils down to Screenconnect not working on a headless machine. If you want to access a computer headlessly to configure it onsite, just use RDP. If you want to put in place something long term then you can ‘trick’ Screenconnect into thinking there is a monitor attached byt using a dummy graphics plug.

This was the response back from Connectwise.

When it comes to the monitor being powered off, Control can only display the output of the graphics driver. If the monitor is powered off then the agent is not going to be able to display anything.
If this needs to be a headless machine then you have two options. The first is to switch the machine to using a generic graphics driver which does require display output.


You can use a graphic dummy plug to trick the machine into thinking there is a monitor attached.

Hope this helps someone.

1 Like

I’ve run into this with headless W10 machines. I end up uninstalling the graphics driver, leaving it with the default driver that Windows ends up using and it’s fine. I also see GUI issues when connecting with other RMM tools into headless systems so it’s not just a ConnectWise thing.