Resolved - Wifi Router in AP Mode Suddenly Stopped Serving pfSense DHCP

One of the first and easiest setup steps when I first began using pfSense, was getting it connected to my Wireless Router. It was as easy as changing the routers operation mode to Access Point, and plugging an ethernet cable into one of the router’s LAN ports as described here.

I’ve never really had issues with this setup before, until now; What appears to have precipitated the problem was my UPS (through which all my network devices receive their power) suddenly shutting down on its own accord (which apparently happens when you plug a non-proprietary RJ-45 to Serial cable into the port). So power was suddenly cut to my devices, including the WiFi Router.

I didn’t think it was a big deal, but after coming back online, it no longer wants to serve DHCP addresses to any connected devices. The devices complain that they are “unable to obtain IP address”.

Things I’ve tried:

  1. Turning it off and on again (both the WiFi Router and pfSense)
  2. Loading a backup of the router config
  3. Resetting to factory defaults and manually entering the AP settings
  4. Checking for obvious error messages in the system, firewall and DHCP logs (I didn’t find any, but maybe there’s a more specific place I could look?)

The nuclear option is to re-flash the router firmware, but of course it’s a pain in the ass, and not entirely without risks. The router hardware seems to still be working, because my wireless devices can connect to it just fine once I factory reset it, and it runs its own DHCP server. But I need pfSense to be the DHCP server. So I figured I would ask the community for advice, has anyone experienced this problem before? If so, how do i fix it :cry:

For completeness, here are the relevant devices on my network:
WiFi Router: Asus RT-AC68U
pfSense: Version 2.4.4-RELEASE-p2 on a Dell PowerEdge SC1425
Switch: Cisco Catalyst 3550
Topology: Modem -> pfSense -> Switch -> WiFi Router

Problem solved. I remembered a few days ago testing some Smart Port settings on my Cisco Switch. I tried putting a smart port preset on the port for my wifi router, and it caused the router to stop working. I promptly removed the setting and things began working again as normal. However, when my UPS cut power to all my network devices, the switch was among them. Evidently, the port settings reverted to the non-working state upon reboot. I SSH’d into the switch and quickly fixed the problem.