Resized disk in XoA but not seeing it in the VM

Using XenOrchestra I increase the size of my VM disk from 48GB to 120GB


However when I run lvdisplay, I still see only 48GB so cannot extend it.

--- Logical volume ---
LV Path /dev/ubuntu-vg/ubuntu-lv
LV Name ubuntu-lv
VG Name ubuntu-vg
LV UUID E0suyX-Rs9R-xxxx-xxxx-xxxx-p7LO-8orcQf
LV Write Access read/write
LV Creation host, time ubuntu-server, 2024-02-28 03:53:00 +0000
LV Status available
# open 1
LV Size <48.00 GiB
Current LE 12287
Segments 1
Allocation inherit
Read ahead sectors auto
- currently set to 256
Block device 253:0```

Looking at the disks under Local Storage, and it all looks fine there too

Did you check using lsblk?

I am betting it is there. you’ll have to do these steps next

something like this

pvresize /dev/sdb
lvextend -l +100%FREE /dev/ubuntu-vg/ubuntu-lv

Thanks, yes

sr0 11:0 1 1024M 0 rom
xvda 202:0 0 120G 0 disk
├─xvda1 202:1 0 1M 0 part
├─xvda2 202:2 0 2G 0 part /boot
└─xvda3 202:3 0 48G 0 part
└─ubuntu–vg-ubuntu–lv 253:0 0 48G 0 lvm /

I then ran

 sudo pvresize /dev/xvda3

And got

Physical volume “/dev/xvda3” changed
1 physical volume(s) resized or updated / 0 physical volume(s) not resized

I tried just /dev/xvda but got

Cannot use /dev/xvda: device is partitioned

After that I run
sudo lvextend -l +100%FREE /dev/mapper/ubuntu--vg-ubuntu--lv

and got

New size (12287 extents) matches existing size (12287 extents).

With nothing changing so resize2fs does not do anything.

You at least got the PV resized which is the first step. Now you need to resize the LV. What are the results of “df -h”?

Filesystem                         Size  Used Avail Use% Mounted on
tmpfs                              792M  1.4M  790M   1% /run
/dev/mapper/ubuntu--vg-ubuntu--lv   48G   13G   33G  27% /
tmpfs                              3.9G     0  3.9G   0% /dev/shm
tmpfs                              5.0M     0  5.0M   0% /run/lock
/dev/xvda2                         2.0G  252M  1.6G  14% /boot
overlay                             48G   13G   33G  27% /var/lib/docker/overlay                                                                                                                                                             2/8a23a8db32d79ceb46b1a9b18b33f66d3d57f5e59a43f07becf7f43127240069/merged
overlay                             48G   13G   33G  27% /var/lib/docker/overlay                                                                                                                                                             2/9d57e6f2a4939381e0c36ad647643404af4b02e7e9270cf51ff9b9a9213c89a8/merged
overlay                             48G   13G   33G  27% /var/lib/docker/overlay                                                                                                                                                             2/c345795ad049e9e1338f9c6bea7c5dc6f7339a6051144c4eae5514e4a2e149f5/merged
overlay                             48G   13G   33G  27% /var/lib/docker/overlay                                                                                                                                                             2/4b71ebeeea8533154a31236f8626d8734db11e618b6d8ad34140df46f3a41ab4/merged
overlay                             48G   13G   33G  27% /var/lib/docker/overlay                                                                                                                                                             2/2bdf373fb3ec80f8b3608a12eff25845d91fcd2715ce76e42a53a08eece85712/merged
overlay                             48G   13G   33G  27% /var/lib/docker/overlay                                                                                                                                                             2/e2492f94a952391652186a2a33a53e064b065afceb1b6d291bf8bec9a73e2670/merged
overlay                             48G   13G   33G  27% /var/lib/docker/overlay                                                                                                                                                             2/1a9ee03dadba2b05de29d3671d377f4312141fd3f790003ab309e8626e635e3e/merged
tmpfs                              792M  4.0K  792M   1% /run/user/1000

Not sure if the following helps

 sudo pvresize /dev/xvda3 -v
  Archiving volume group "ubuntu-vg" metadata (seqno 5).
  Resizing volume "/dev/xvda3" to 100657152 sectors.
  No change to size of physical volume /dev/xvda3.
  Updating physical volume "/dev/xvda3"
  Creating volume group backup "/etc/lvm/backup/ubuntu-vg" (seqno 6).
  Physical volume "/dev/xvda3" changed
  1 physical volume(s) resized or updated / 0 physical volume(s) not resized

It’s been a minute since I have done this. I can’t remember if you specify the mapper for you apply this right to root. Try to run the lvextend command on “/“ or root

You mean

sudo lvextend -l +100%FREE /

Have to step our for a few days, will try when back

Alas, can’t get this right either.

Ok so booted off a GParted USB and then resized the partition, after which I could run lvextend and resize3fs.

Thanks for your pointers.