Raspberry Pi Web Server behind pfSense - Port Forwarding Question


I’ve gone through the trouble of installing Raspberry Pi OS Lite and apache2 on my Raspberry Pi 3b and am having an awful time accessing it from my public ip address because the pfSense webGUI is loading instead of my Pi-Webserver unless I try accessing my public ip in an Incognito Session to which it fails to load any page with an error that the page took too long to respond. If I put my external ip into my phone while on cellular data it loads my webpage perfectly fine.

My configuration is:
I have port forwarding enabled on TCP Port 80 to (pi-webserver)

WAN Firewall rule created for Port 80 pointing to (pi-webserver)

pfSense WebGUI is using a non-standard port

Any help would be greatly appreciated!

Go under System, then Advanced then check the box to turn off WebGUI redirect

Hi Tom, Big Fan!

Thank you for taking the time to help out. I’ve done what you suggested but it appears to be doing the same thing. I manged to find a post on netgates forum about turning on NAT reflection as well and have done so. It seems to be working now. Thanks again!

1 Like

NAT reflection would have been the next thing I would have suggested to check. Happy to hear that it is working!

1 Like