Puzzled: DNS Resolver Hostname Override

Just recently deployed a SG-3100 on my home network. In setting up pfSense, I assigned LAN IP Added a Hostname Override in DNS Resolver specifying that address along with the hostname and domain. Applied the change.

The client device is a MacBook Pro on the OPT5 interface. The mDNSResponder was stopped. DNS cache was flushed after which MDNSResponder was restarted. OPT5 is assigning addresses in the 10.24.x.x subnet.

When I enter the FQDN specified in the Hostname Override, it doesn’t get resolved and Google search page is presented. Disappointed, I checked the Network properties on the MBP. DNS server and gateway match the static IP of OPT5.

Screen Shot 2020-04-24 at 9.04.05 PM

Did a little more research from the command line using dig and nslookup. I performed dig using both the IP and then just specifying the FQDN. Both listed the IP specifed for the override but I noticed that the Server addresses differed.

Screen Shot 2020-04-24 at 7.49.41 PM

Screen Shot 2020-04-24 at 7.51.22 PM

Here’s the nslookup -
Screen Shot 2020-04-24 at 8.29.28 PM

I also tried running a traceroute but it never found my pfSense host- it was all asterisks for each hop.

Specifying either the pfSense LAN IP or the IP of OPT5 in the browser will bring up the login page in both instances.

Please enlighten me. What did I miss in setting this up?

Thank you.

I am not clear on what you are trying to achieve, the dig results look like they are working, but are you saying the browser does not come up with the same?

When I enter the FQDN, ‘apollo.gatekeeper.lan’ into the browser it does not bring up the pfSense login page. I thought that having the hostname override would accomplish that. Instead, I get a page of search results from Google.

Sounds like your browser is ignoring your DNS entries. Are you using DoH? https://en.wikipedia.org/wiki/DNS_over_HTTPS

No, I’m using Safari for pfSense administration.

I would try another browser and confirm it’s pulling the right DNS.

Interesting. When FQDN entered on Safari or Chrome a page of Google search results comes up.

With Firefox- it works!

Curious as to why the FQDN won’t work for the other two browsers.

Hey – not to be disparaging – did you clear the cache on the other two browsers?

I did with Chrome in addition to flushing the DNS cache, but not Safari.
Tried clearing the cache for Safari, and Chrome again.
No bueno. Entering the FQDN brings up google search results on both.