Problems with internet access to vlan and NAT function for PS4

Hi all :).

First I have to say sorry for my English, I am from Norway and have some problems writing English.

But now to my vlan issues and NAT (PS4) issue.

I do not get internet access on the vlan I have created in my pfsense firewall. I have tried to follow Tom’s videos with Norwegian subtitles during his video, but I may have lost some configuration which I added.

Attach some screenshots from my google disk so you can see what I have done: pfsense help - Google Drive

Could there be something inside pfblocker that is a bit of a joke with me?

I’m struggling with my Playstation 4 being unstable on my network. when I take a network check, I get that it is on NAT3. What I have read up on, I have to do something with inside pfsense.

Hope there is someone here who can give me tips :).

Love from Norway :).

Personally I don’t like those allow any rules, as it’s unclear what is actually happening.

I’ve setup my rules (for vlans) to allow traffic to other vlans and another to allow out of the the WAN.

You can use your vlan alias as the destination on the first rule, on the second invert the alias and set the gateway to the WAN (then it goes anywhere except your LAN/vlans which is your WAN). Use protocol IPv4 TCP / UDP.

If you block all ports like I do, you might want to add an alias for ports and add them in as and when you need them.

I would also use a computer / laptop to test that your vlan traffic is moving as you want it before testing it on an xbox (I don’t have one but assume you might need to compensate for it). This is assuming you have configured your vlans correctly in pfsense and on your switch.

LOL I have a place in Oslo and it looks like your English is better than mine !!

Where it says “States” 0/0 that tells me no traffic is going over those rules so the issues is more likely with the VLAN not being configured properly either at the switch or wireless access point. Does the PS4 get an address from the DHCP server?

I have vacation now, so have almost no time to troubleshoot the problem. But there has been a funny situation that I have to share.

Do not know why, but suddenly I got net to all my vlan. it worked for 3-4 days, then the network went down again. all vlan, including the main network (

I discovered a new problem. My home exchange from my fiber network company (Altibox) would not work 100% in bridge mode. I and one from support from my fiber network company came from the fact that one port that should go from the home exchange to my pfsense router had a link flap problem.

The link flap problem is now fixed. I had to restart the pfsense server, because I wanted to start rebuilding it again.

When I have configured everything again, I still struggle with the internet to the vlan’s. I’ve watched Tom’s videos, but I do not understand why I do not get an internet connection to my vlanes I have set up. I get ip but not internet connection

Some info about my network equipment:

Firewall / Router: PFsense

Switch: Netgate GS308E


Thought I would reset everything again, then record a video where I set up a vlan just to show you. If you have no tips to come up with :).

I know it may be the wrong mindset, but I suspect there is something wrong with my switch.

I have not looked at the NAT issue of my PS4, it is because my TV is broken :laughing:

I use Netgear switches, I recall when first setting things up, I needed to configure the switch and pfsense independently for vlans, then connect the two. For some reason if the two where connected during configuration I ran into issues.

What you are trying to say is that you had to set up the switch before connecting it to pfsense?

Yes, so configure the vlans on pfsense. Then configure the vlans on the switch. Then connect the two.

Then there must be something wrong with the switch.

Thought I should order a new switch from Unifi.

Not sure if I should buy Ubiquiti Unifi US-8-60W POE gigabitswitch 8 or a 16 or 24 ports that I can put in rack case