Problems with FreeNAS VM + VLAN + ESXi + Brocade switch + pfsense


I have installed FreeNAS 11-3-U1 on a ESXi VM.

ESXi VM - ESXi vswitch on VLAN ID 4095 - Brocade switch with tagged ports on VLAN 40 (pfsense is on it too with a tagged port) - pfsense with VLAN 40 configured and firewall rules allowing traffic.

FreeNAS VM Shell:

ESXi FreeNAS configuration:

Brocade switch configuration (I have tested that vmnic4 and vmnic5 are on 1/1/13 and 1/1/14 switch ports disconnecting cables and refreshing ESXi UI):

pfsense configuration:

pfsense vlan40 rules configuration:

Please, let me know if I missed any data that will be helpful for my problem resolution.

if I delete vlan40 interface in FreeNAS and set vmx0 to address and default gateway to and then set my ESXi vswitch configuration to VLAN ID 40, then I have networking and I can see on pfsense that it is tagged with vlan 40 ID. You can see it in the next image:

so, if I am correct, the problem is on the FreeNAS VM configuration or on ESXi vswitch when configuring it as VLAN ID 4095, but this VLAN ID should set VGT mode and the vswitch port in trunk mode.

all help will be appreciated. Thank you in advance.

Whenever I want a VM on ESXi to have an interface with a VLAN, I do it like this:
-ESXi VLAN-aware switch configured on the ethernet port of the host (just a regular virtual switch)
-VLAN created within that virtual switch (in your case 40)
-virtual interface in the VM configuration set to use that VLAN/network
-the host OS inside the VM doesn’t know its in a VLAN at all. Effectively, its virtual port is “plugged into” an untagged port for VLAN 40 on the virtual switch.

1 Like

I am not sure to have understood what you are saying. You just create a vswitch on ESXi with VLAN ID 40? but I want a trunk vswitch because I am going to use different VLANs for my FreeNAS jails.

Thank you for answering :slight_smile:

I did once use the special-purpose vlan 4095 in order to access multiple VLANs from within a client, and I don’t remember having any issues with it. In general though I’ve used port-groups with regular VLANs. I recommend first setting that up so you can make sure nothing else is an issue.

1 Like

Ok, more news.

The problem is FreeNAS. I have created a Debian VM in the same ESXi port group as a FreeNAS jail. ESXi was on VLAN ID 4095, so VTG is enabled and 802.1Q tag is managed by guest system, not by ESXi. The Debian VM worked at the first time on vlan41.

on FreeNAS side, I have set up vmx1 on the mentioned port group, without address, then I have created vlan41 with vmx1 parent interface, without address too. I have created bridge41 with vmx1 and vlan41 as members.

I have set up a jail with address and gateway, on “network properties”, i have configured interfaces vnet:bridge41 and vnet_default_interface to none, because if I set it to auto, then it adds vmx0. if I do an ifconfig I will see vlan41 and vmx1 as bridge1 members. but the jail cannot see

Even if I start clean and do, for example a ifconfig vmx0.40 create vlan 40 vlandev vmx0 inet it cannot find

(I have two VLANs, 40 and 41, 10.0.XX.1 is the gateway on them)

You need to configure ESXI so that new VLAN 40 is added to your vswitch

1 Like

The switch config was shared in the first post and I can confirm as a Brocade / Ruckus switch user that the VLAN looks correct for what is happening here.

1 Like

Hello, thank you for posting :slight_smile:
The problem is on FreeNAS side, because if I add a Debian VM on the same vswitch, I have no problems to configure it on the VLAN.

At present, these devices are capable of full VLAN processing in hard- ware: ae(4), age(4), alc(4), ale(4), bce(4), bge(4), bxe(4), cxgb(4), cxgbe(4), em(4), igb(4), ixgbe(4), jme(4), liquidio(4), msk(4), mxge(4), nge(4), re(4), sge(4), stge(4), ti(4), txp(4), and vge(4).

My ESXi virtual device was vmx. I have changed to em0 and it worked like a charm!! I am very happy :slight_smile: