Problems with 4G and DNS

We have an old 4G modem from Verizon that has been unsupported and EOL for years. We are finally getting around to replacing it and I pulled the sim card out and put it into a new Netgear LM1200 modem. It powered on and found a the network but only cached DNS sites would work.

I tried bypassing the router and was given an ipv6 address on my laptop along with 3 ipv6 DNS addresses. Even here I was only able to access Google, Bing and Wikipedia. Trying to connect to IMDB gave a DNS probe error.

I put the SIM back into the old modem and was still getting the same issue. Am I missing something? It seems to be related to DNS but I’m not sure what to check next or if 4G or Verizon have special settings or rules for their network.

I know you said cached sites are working, but can you verify you’re able to ping out to the internet? (could try pinging,,

Also, I would double check the APN settings on the old modem to see if there’s anything you need to setup on the new Netgear modem. More than likely you’ll need the APN information entered for it to know to connect to an Access Point. Oddly enough, Verizon doesn’t seem to have that information posted officially online, so you could try these settings here as other forum posts seem to link here: Verizon Wireless APN Settings - BestMVNO

Those settings look like they point you at the vzwinternet APN which should be all you need, but it appears there are a few other options for if you had a different plan or even a static IP listed on the instructions for their hotspot here: Edit Access Point Name (APN) - Verizon Jetpack 4G LTE Mobile Hotspot MiFi 4620L

Also, Netgear has a short writeup of getting to those settings: How to configure APN settings for 4G LTE Modems | Answer | NETGEAR Support

You may need to just contact Verizon though and confirm the APN settings and that SIM card is still active (I doubt it’s not but worth noting. Can’t tell you how many customers had autopay going and forgot their card expired).

1 Like

Thank you so much for all of this. Something far faaaaar dumber was happening. Modem worked fine and then once it got put into its closet, it lost 4g signal due to some steel reinforcement behind a wood facade. So it worked fine when I was troubleshooting it but then acted up when I put it in the closet.

So basically layer 1 strikes again, or is it layer 0 if I was the one that didn’t realize it.

Hahah oh that’s great! I guess I assumed wherever you had it installed used to get signal just fine but you definitely cannot rule out your layer 1! Also for all intents and purposes, I believe the user is typically referred to as layer 8.

1 Like