Problem with pfsense update to CE 2.7.2

Hello every one,

i tried to update the CE Version to 2.7.2, but it failed. First time ever!

Installed packages to be REINSTALLED:
pfSense-boot-2.7.2 [pfSense-core]

Number of packages to be reinstalled: 1

[1/1] Reinstalling pfSense-boot-2.7.2…
[1/1] Extracting pfSense-boot-2.7.2: … done
Updating the EFI loader
install: //boot/efi/efi/boot/INS@CW660s: Input/output error
pkg-static: POST-INSTALL script failed

Any ideas?
Thanks for great content and help :slight_smile:

Not an error I have encountered, have you rolled it back and tried again? Also worst case grab your backup, reload, and restore.

It is still on 2.7.1. So i can´t roll it back.
After I retored from my backup i tried to update again.
Unfortunateley same failing message.
Next step on my list: i set it back factory defaults try to update und then i restore from backup. Same failing message.

I think have to do a clean reinstall.

Perhaps give this a try

Thanks. But of course the re-install did solve all problems.

I had the exact same issue and several other people on the pfsense forum. netgate posted a procedure to fix it but I did have to power-cycle the devices (both SG1100 and my bare metal unit) in order to make them work again. Bit of annoyance if it happens on a remote device.

EFI partition size may be the problem for some users trying to go to v2.7.2

There are some useful threads on the r/PFSENSE subreddit, and links to which indicate that an undersized EFI partition could be the problem - particularly for installations first done some time back, which have been only updated since. While installations first created more recently will not have the problem.

There is apparently a way of fixing this, step-by-step, increasing the size of the EFI partition etc - but it is not easy, time consuming with potential to fail badly. Conclusion is same as what Tom says below - the smart approach is to backup the configuration and reinstall from scratch.

I am planning to do that for my box. But I need to get all downloads lined up before I start - since most of my network will not work properly if I take the pfSense box out of the circuit! But I suspect I am not unique in that.



1 Like

just yesterday I found out that my pfsense boot drive was 109% filled. turned out to be suricata and snort logs which I deleted but the system would still not work properly. i reset to factory defaults and restored a config, still not working correctly - it would not resolve the package repo. i got fed up and did a fresh install, restored the config and everything was happy again. i guess starting fresh sometimes is just the ticket!

I encountered this problem and indeed it was due to the boot efi size being 784KB (ada0p1) rather than 200MB. Attempted to expand the partition (ada0p1), but was unsuccessful and ultimately reinstalled 2.7.2 (making sure the partition was 260MB) and restoring the configuration.

FWIW, I just did an upgrade, and it predictably failed. I have now had 1 sg1100 corrupt itself randomly, I had to buy a second one and ship it to my parents as this is a box I use for them. I got the old unit back, was able to have netgate support send me the image to flash and got it working again, but having it fail yet again on update… I now consider sg1100’s to be garbage.

I have recommended them to two of my friends, one had his come DOA, the other has had his corrupt once randomly, and had this same update issue I and everyone else on this thread seems to have. I have 0 issues running pfsense on my own hardware, but holy cow, no one should ever buy an sg-1100. Between myself and 2 friends, we have had 5 sg1100’s, all but 1 has crapped out at some point, and 2 have crapped out twice.

If I could could get my money back…… I absolutely would.

For additional info, this was going from an early version of 23 to 23.9.