Prevent USB drive from spinning down

I have NextCloud running on a RaspberryPi4 (yeah, I know - not a huge server etc :rofl: ) using Ubuntu server. For the data, I have a 6TB Ironwolf HD connected via USB. The problem is that it keeps spinning down after a while. One thing is that this sometimes makes response times longer, but my main concern is failure. That drive is made for spinning 24/7 and I am afraid the constant spinning up/down will make the drive fail faster.

Is there a way to prevent the drive from spinning down? Ubuntu server (no GUI) and connected via USB3.

Not sure if there is a way to update the firmware to tell it to stop but you could look at creating a cron job to touch a file on the system and that might stop it from spinning down.

Here is an article on spin down commands for PI maybe you can find some info here for setting parameters for spin down to be 0?

Also many drives from WD and Seagate can be parameter written with their drive utilities. Look at Seatools on this link:

No real help with your problem, but you might switch over to a “different” style of connection in the future. Unfortunately the Kickstarter is full (no offers) but it might be an interesting choice for many of us: Argon EON: 4-Bay Network Storage powered by Raspberry Pi 4 by Argon Forty — Kickstarter

Yes, I know they are still USB connected (for now), if compute modules were more available it would make a nice little NAS with a real PCIe drive controller.

I do have an Argon One V2 case for my Pi4 8GB, seems to be a nice product so if the NAS is as good, it would be worth it for many people looking for a “simple” NAS for media streaming and storage. A couple of reviews on the NAS on Youtube.

Thank you. If I can not do it another way, I will use that.

Greg,

I had a look at the Argon One case, and although it looks nice, it does not offer any real advantages over the setup I have right now: RPi4 8GB RAM with a processor cooler. OS on a NVMe through USB3 and data on an Ironwolf 6TB HD.

A NAS built on top of RPi is a poor NAS. I would rather go with a proper NAS and mount a folder on the RPi. But that is for a future preoject :grinning:

Hi…I sorted it out with some dabbling in the event that any other individual is as yet having this issue. My WD 2TB HDD is connected to the “Expert” plug on my flood defender so it must be dynamic all the ideal opportunity for all the other things to have power.

b00st3d, you were in good shape, yet on “Cutting edge Power Options”, you need to debilitate “USB Selective Suspend Setting” under “USB Settings”. Brings about the ideal result, and I don’t need to empower compose cacheing (not suggested, I lost 1TB of information that way).