Pop OS GUI Problem

I installed pop os on my PC alongside windows almost a year ago and everything had been working perfectly fine until 1 or 2 weeks ago when the GUI (GNOME) stopped loading when turning the computer on.
I know that it is a GUI problem because I can ssh into it, I am quite new to Linux Desktop so I don’t know how to fix this. Can someone help me?

btw it is currently running Pop OS 18.04, it has an AMD graphics card and an Intel CPU.
thanks in advance

So if your logged into PopOS and are at the command line – what happens if you type gnome-session? You could do this through and SSH connection if you have setup SSH to tunnel X sessions and you have a local X server running. Oftentimes however its easier to boot the OS and try that way rather than through ssh.

I SSHd into my pc and ran gnome-session and got nothing back. No errors, nothing.

Which GPU are you using? Might be a 3rd party graphics driver issue.

its a XFX R9 390.

That was my first taught because not long ago the same thing happened and it got fixed with apt-get update & upgrade but i’ve tried that a few times and hasn’t fixed it.