POP OS Error when in Nvidia graphics mode for external monitor use

I have a System 76 Oryx Pro with Intel and Nvidia graphics. The laptop or maybe PopOS require that I reboot in NVIDIA graphics mode to connect to an external monitor.

Thereafter everytime my laptop wakes from suspend I get the following message.

Apr 02 11:40:53 pop-os kernel: iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS

The first time I wake from suspend the message is displayed one time. The next time, two times. Until a day or two later I have the above message displayed many times, say a dozen or more.

I submitted to System 76 but support said not to worry about it. But it seems to me that the laptop acts a little wonky when the messages get to be about the 10 or more count. Could be paranoia but to play it safe I reboot into Intel graphics mode and then when back into NVIDIA to reset the message count so to speak. And OCD or not, I don’t like seeing errors thrown if I can fix it.

I had done some research and read a post somewhere where the problem went away when they upgraded to 20.04. I was hoping that would be the case for me as well, but I still get the error message so I thought I would post here since Tom uses Pop OS and he eat, drinks, and lives Linux. I also plan on posting to Jay LaCroix Linux.tv if I can find a way to do so.

Lastly, I do see another set of errors when I reboot and don’t know if related to the above problem.

Failed to unmount /oldroot: Device or resource busy
Then two more of the same message but for different deeper paths.
/oldroot/dev and oldroot/dev/pts

I am brand new to Linux so have no idea on how to troubleshoot. I am taking a free Linux course by the Linux foundation but it is pretty basic so far.

Thanks for everyone’s time!


I just took a look at another topic Where do I go for help with Pop OS and saw the suggestion to run dmesg

I found the following five line for every time I believe the system generates the message in my original post. I had read somewhere that someone said the error was caused by a BIOS issue. Since the laptop I have is from System 76 I believe they maintain the BIOS so I am going to submit an update to my support ticket.

I am going to mark this as solved, but if anyone has another suggestion on what I should do to fix or investigate further please let me know.


[ 9474.584076] iwlwifi 0000:00:14.3: RF_KILL bit toggled to enable radio.
[ 9474.594191] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
[ 9474.712621] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
[ 9474.777430] iwlwifi 0000:00:14.3: FW already configured (0) - re-configuring
[ 9474.785404] iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS