Pop OS 20.10 Latest Kernel Update Borked my Lappy

@LTS_Tom Nasty surprise after installing the latest kernel and video driver updates 3/30/2021 for Pop OS 20.10. After reboot, the system hung.

  • Set the timer for 5 mins, no progress
  • Had to hold the power button to shutdown
  • Switched over to verbose mode during next boot
  • System halted with a Kernel Panic

Error Message: Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b

Able to work around the issue at the moment by pressing the space bar at boot up and selecting the “Pop!_OS (Pop_OS-oldkern.conf)”

System Info:
Dell Latitude E5470
CPU: Intel i5-6300U (4) @ 3.000GHz
GPU: Intel Skylake GT2 [HD Graphics 5
Memory: 16BG DDR3
HDD: 512GB LUKS Encrypted Drive

Troubleshooting

  • Rolled the install back, was able to duplicate the issue again when upgrading
  • Was able to successfully apply the update on other hardware including VMs and two lab desktops (dissimilar hardware), so the update is not broken for other things
  • Wiped the laptop and reinstalled the Pop OS 20.10 from USB image (AMD/Intel) 12 (pop-os-20.10_amd64_intel_12.iso) . The Install completed without issue; During first update, the kernel update and video drivers caused the system to hang again at next boot
  • Again wiped the laptop and reinstalled Pop OS 20.10 with the current image (pop-os-20.10_amd64_intel_14.iso). Install hung with a kernel panic and was not able to complete install
  • Using v14 image, was able to successfully clean install on dissimilar hardware, so the installer is not broken with other things
  • Played with some of the BIOS settings, specifically storage controller mode (RAID vs AHCI), and verified that secure boot was disabled. No change, system hangs during install with v14 image or after updating from install from v12 image
  • I use an E-series port replicator (docking station) and tried with and without the system being attached, no change

At this point wondering if this is a hardware issue of either a failure or incompatibility with the video drivers or the kernel. I think I read somewhere the new video drivers were not kernel drivers but “live” in the user space.

Searching the error seems to be related to an issue with GRUB configuration finding the drive

Trying to get my hands on another E5470 to do a side-by-side compare with same hardware.

Doesn’t seem to be any posts in other well traveled forums on the subject related to the recent update and Pop OS. Anyone with any thoughts, input or anything, let me know and thanks in advance!

Will post updates if I figure out a resolution

“Systemd-boot is the bootloader for Pop!_OS 18.04 and above while GRUB is the bootloader for Ubuntu. It takes care of getting the operating system started up. It is also responsible for allowing the user to select between multiple operating systems at boot. Sometimes, GRUB/systemd-boot can break, and it may not let you boot into your computer to fix the problem.”

Systemd-boot not GRUB for Pop OS

Update: Followed the steps for repairing systemd-boot for encrypted SSD drives. All the repair commands executed without error. Rebooted, system hung at a later time with the same error. Support ticket opened

Additional Testing Results

  • Re-seated memory modules; no change
  • Isolated memory modules by installing one at a time, then tried to boot v14 media; no change
  • Swapped SSD HDD out with a new SSD HDD; no change
  • Swapped SSD HDD out with a new NVMe HDD; no change
  • Completed all hardware diagnostics with no failures
  • Tested all USB boot media, no failures. Can complete the install on other systems with non-similar hardware
  • Using a client’s older E5550 Latitude, was able to successfully install 20.10 v14 with no issues
  • Using another E5470 Latitude with similar hardware; Was able to duplicate the issue on the same model with similar hardware
  • Using Ubuntu beta builds for 21.04; Was able to duplicate the issue. System hangs during boot from media.

Final item tested was using Pop OS LTS 20.04 v26; Was able to duplicate the issue

  • No issue booting and installing from earlier versions of the 20.04 image
  • Used v23 of 20.04 LTS with no issue
  • Successful install of 20.04 LTS v26 on Latitude E5500

Next steps

  • Have a client with a E5470 with Nvidia discreet graphics I’m trying to get to test on with the latest Nvidia image of 20.04 LTS and 20.10
  • Testing with other distros built on kernel v 5.11.0

Other notes: Researching the crash, it seems the system hang happens at or before detection of the video subsystem. Both of the E5470 Latitudes tested contain Intel Skylake GT2 HD 520 integrated graphics.

Looks like it’s not just my system. Looks like the issue is rising up in the number of incidents