Pihole Install Error [Fresh Ubuntu Install]

Hi Lawrence,

I was following your YT video on the pihole install and I am stuck at install step. This is a fresh ubuntu updated install in a VM. Here’s what i get when i run the install with Method 1 and Method 2:

I’ve been wracking my brain where am i going wrong?

The recommended command git clone --depth 1 https://github.com/pi-hole/pi-hole.git Pi-hole is stuck and does’t move past.

Earlier i had install it through docker which worked fine however, i couldnt get the Server IP changed to the machine private IP (but was able to access the admin console via machine local IP instead of Server IP showing inside pihole. weird. – i did though made the connection changed from NAT to bridged from VMware network editor. I think that was the reason ?

It’s been a few years since I have used PiHole so you might want to post in their forums.

just tried Method 1, it brought in the repo (took 8 sec) and was able to install.

I always use this method for install…

curl -sSL https://install.pi-hole.net | bash

Here is what i get with curl command

   pihole-pc@ubuntu:~$ sudo curl -sSL https://install.pi-hole.net | bash
[sudo] password for pihole-pc: 

  [✗] Root user check
  [i] Script called with non-root privileges
      The Pi-hole requires elevated privileges to install and run
      Please check the installer for any concerns regarding this requirement
      Make sure to download this script from a trusted source

  [✓] Sudo utility check

  [✓] Root user check

         :cccclll:.      ..,,
          :ccccclll.   ;ooodc
           'ccll:;ll .oooodc
                 .. ','.
        .........  ....  .........
        ..........      ..........
        ..........      ..........
        .........  ....  .........

  [✓] Update local cache of available packages
  [✓] Disk space check

  [✓] Checking apt-get for upgraded packages... 6 updates available
  [i] It is recommended to update your OS after installing the Pi-hole!

  [i] Installer Dependency checks...
  [✓] Checking for dhcpcd5
  [✓] Checking for git
  [✓] Checking for iproute2
  [✓] Checking for whiptail
  [✓] Checking for dnsutils

  [✓] Supported OS detected
  [i] SELinux not detected
  [i] Using upstream DNS: Quad9 (filtered, DNSSEC) (,
  [i] Static IP already configured
  [i] Unable to find IPv6 ULA/GUA address, IPv6 adblocking will not be enabled
  [i] IPv4 address:
  [i] IPv6 address: 
  [i] Web Interface On
  [i] Web Server On
  [i] Logging On.
  [✗] Check for existing repository in /etc/.pihole
  [i] Clone https://github.com/pi-hole/pi-hole.git into /etc/.pihole...
  Error: Could not update local repository. Contact support.

this has been rasied on pihole forums. Not sure what am i missing for a fresh ubuntu install. some dependencies or configs? docker pihole was a smooth install.