Pi-Hole - resolve local hosts without using FQDN

Hi Folks - feeling a little “dense” here…

The configuration is:
DHCP is provided by pfSense. DHCP options includes domain name and domain search list configured to include internal domain name.
Internal DNS is configured with two internal DNS servers: pfSense and Synology (overkill yes, but anyway…).
Pi-Hole configured to use my two internal DNS servers as the upstream DNS servers. Never forward non-FQDN A and AAAA queries is unchecked. Never forward reverse lookups for private IP ranges is unchecked.

Pi-Hole is working but for internal hosts I have to specify the FQDN. I do NOT want to add all DNS entries to Pi-Hole (i.e., /etc/hosts).

Am I missing something or is this the way that Pi-Hole works? (e.g., requiring all internal hosts to be added to Pi-Hole)


It appears that this may be an issue with Ubuntu 22.04. Windows 11 appears to work fine resolving local hosts without using the FQDN. I’ll post updates as I investigate further.

Seems to be resolved. Closing this one…