pfSense WAN with public static IP (ISP MEO)

Heya

I’m currently working on my first deployment and one of the things I want to do is isolate my client’s devices from whatever the ISP deployed for their infrastructure. To achieve this I bought a SG-2100 and asked the ISP to open a bridge. Although they gave me the static IP, gateway, subnet mask and public IP I didn’t manage to have internet access. None of the technicians I talked to know pfSense, so here I am.

I have followed the guide on the documentation for this scenario, but I feel like there is something else

I have also tried to find a guide with the configuration for the same ISP (business client) using pfSense, but no luck. Closest I got is the config for Unifi USG, but I don’t know how to translate it to work with pfSense (the thread is from a Portuguese forum, the specific part of the config found is in the last reply) GlobalConnectPack c/Ubiquiti IP Alias, PublicIP | ZWAME Fórum

Can anyone help me with this? Thanks in advance

A static public IP assignment is simply putting in and assigning the IP address to the WAN and then adding the default gateway. That forum link says the WAN is on VLAN 20, is that part of the ISP’s instructions?

Thanks for the reply Tom!

That’s what I’ve tried. I’ve set the WAN to the IP, mask and gateway they gave me. The last technician from the ISP I talked to said I needed to set the public IP using “IP Alias”, which I also did. Furthest I got was the WAN showing up as “connected”, but no internet.

From other forum topics, I understand that VLAN 20 is already tagged on the ISP router (except in Technicolor routers, which I don’t have) when they open the bridge. That would mean that I don’t need to also tag that VLAN on the pfSense router, right?

I’m afraid there’s something else I’m missing (like NAT or routing?). Sorry if I sound too newbie on this or made something unclear or confusing :confused:

There is nothing special you have to do to get pfsense working with routing out of the box, just assign the static IP and the default LAN rule allows traffic. Try plugging in a computer/laptop with the static settings and see if it works.