pfSense WAN_DHCP Offline, Packet loss

Hello People,

I’m currently using a Netgate firewall, and my gateway is currently showing as “Offline, packetloss” (See pic below). I’m wondering if this is because something with Dynamic DNS is not being updated correctly. I went ahead and setup the CRON package to check if my IP has been updated and it seems like it’s working as my interface WAN matches my IP found in the Dynamic DNS service. The IP address that is under WAN DHCP is different and doesn’t match my interfaces or dynamic DNS IP. Is this why it says Status Offline, Packetloss?

The cron package checks every 5 minutes for a new IP. Should I decrease the number of checks?

How do i fix the “offline, packetloss”?

You don’t have to use a cron job to check for DDNS. Pfsense supports a multitude of registrars out of the box. You can find this under service—>dynamic DNS and this might solve your problem.

Or you can run a trace route to find the next hop in your network to determine your gateway IP.

its my gateway that doesn’t have the correct IP. My interface IP is correct. Should I just kill this service? How do I update the gateway IP? My gateway IP is correct its just that I have this Offline, Packetloss 100% status.

I just deleted it as it didn’t match my current IP.

Don’t recall ever setting the IP address of the WAN gateway.

I think you have messed something else up, you need to inspect your logs to see what is happening.

The issue is with your ISP, check your modem, reboot it.

your WAN ip could be x.y.73.6 but the GW could be x.y.72.1 which means the GW handles all of the .72 and all of the .73 subnet.

Ah, yes. My wan IP address is .28.242 but my gateway address is .28.1. How do i correctly configure my gateway so that i dont see that Offline, Packetloss error?

So under interfaces I see I see my WAN as the .28.242 then under gateways i have .28.1

if you ping from the wan interface using the pfsense ping tool, is this where you see packet loss? if it is, either your cable modem is hosed (I think you said you did a reboot), the cable between the PFsense and cable modem or an ISP issue.

if you want to eliminate PFsense as the issue, unplug the wan from your PFsense, plug it into a PC (make sure the firewall is on) and the PC is set to dynamic and see if you have packet loss.

I’m able to ping my WAN address and I get 0.0% packet loss. I cannot ping the gateway address.

Is my gateway suppose to be set to my WAN address?

no , your WAN address is provided by the ISP. The gateway is an ISP piece of gear at some other location. ICMP (which ping is part of)is a low priority protocol, so if there is high CPU, high traffic, networks will drop ICMP before other traffic. Packet loss is TYPICALLY a bad cable, most times. however if the packet loss is between your cable modem and your the gateway, you need to contact your ISP. I would set a computer to DHCP, unplug the PFsense wan and plug the cable modem into the PC. See if you can replicate the packet loss. if you can, then i would call the ISP.

Edit- sorry still working on first cup of coffee. if you are configured with DHCP and the PFSense box can not ping the gateway, you need to contact the ISP.

Okay. So, there is an issue on the ISPs end? My internet is working though. My firewall cannot ping the gateway address. Is it possible there is just something that is configured incorrectly on my end?

possible your ISP blocks ICMP to the gateway device then. I didnt realize the internet was working.

Thats what I was thinking. What do I do if that’s the case? The gateway is required to have ICMP traffic to work?

Thank you! It does seem like there is some issue with the gateway. I’ve been talking to my ISP.

It’s possible they don’t allow ICMP to the gateway.

well my ISP is telling me there is no issue on their end at all, but my gateway is still saying Offline, packetloss. Although they are escalating it to some higher team level.

You add a monitoring ip to the gateway settings,

System - Routing - Gateways . You can add your our monitoring ip (could be your isp dns server, google

If you have failover configured, this is how the system works out if one of the links is down

Okay. I setup testgate to monitor and you can see it’s online.

The red blocked out IP’s are the same.

What does this mean?


You may have two gateways configured (one maybe redunant)

Under Interfaces - Interface Assignement - Click on the wan , you will find IPv4 Upstream Gateway (This is the gateway in use).

You can delete the other one, under System - Gateways

I updated my gateway to monitor through and that fixed the problem!


What does changing monitoring IP to do?

Instead or monitoring the gateway , which in your case isnt pingable, monitoring will ping instead of the gateway. The point of this is if the monitored IP stop pinging, its assumed, your route / Internet is down. This is used if you have more than 1 ISP so the firewall knows one is down and to send traffic to the other one. If you have an internal monitoring server (SNMP) an alert can be sent to tell you its down.

1 Like