pfSense /w CGNAT

From what I have been reading since I am double NATing (pfSense & a CGNAT, T-Mobile 5G Home Internet) it is best to disable NATing on pfSense. I am setting pfSense to Disable Outbound NAT rule generation.(No Outbound NAT rules) but struggling with what to do next. I am figuring that I need to set a Static route to the CGNAT Devices with provides a address. I have tried a few things trying to get it part correct. So i have to keep rolling back the pfsense configuration to an earlier version.
Sadly this is my only option for high speed internet where I am located. :frowning:

Are there any other settings in pfSense that I should be looking at once I get past this part? If this can get working properly I am looking at setting up Tailscale/Headscale to punch a hole thought the CGNAT to regain access to my network/home Lab while remote.

Thanks for the help.

Don’t disable NAT in pfsense, even if you are double NAT. Tailscale is a good VPN to use when stuck behind CGNAT.

1 Like